summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-12-23 19:06:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-29 17:40:28 +0100
commit61ec8928c7fee048fea37558508eb0a80022684b (patch)
tree4a1beca84e27a3ed091c6f438f8d8a6ccb12c132 /gnu/packages
parenta2c66d18a565d85e94ea305429878d05e88b982a (diff)
downloadguix-61ec8928c7fee048fea37558508eb0a80022684b.tar.gz
gnu: r-snpstats: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-snpstats): Move from here...
* gnu/packages/bioconductor.scm (r-snpstats): ...to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm27
-rw-r--r--gnu/packages/bioinformatics.scm27
2 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3b8dce30e5..ff9e26bbde 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9540,6 +9540,33 @@ integrates with pathway and gene set (enrichment) analysis tools for
 large-scale and fully automated analysis.")
     (license license:gpl3+)))
 
+(define-public r-snpstats
+  (package
+    (name "r-snpstats")
+    (version "1.40.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "snpStats" version))
+       (sha256
+        (base32
+         "1298a71swwav53yf9kfqkdpach3818plqcbw0lgb6sibs8y8ff24"))))
+    (properties `((upstream-name . "snpStats")))
+    (build-system r-build-system)
+    (inputs `(("zlib" ,zlib)))
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-matrix" ,r-matrix)
+       ("r-survival" ,r-survival)
+       ("r-zlibbioc" ,r-zlibbioc)))
+    (home-page "https://bioconductor.org/packages/snpStats")
+    (synopsis "Methods for SNP association studies")
+    (description
+     "This package provides classes and statistical methods for large
+@dfn{single-nucleotide polymorphism} (SNP) association studies.  This extends
+the earlier snpMatrix package, allowing for uncertainty in genotypes.")
+    (license license:gpl3)))
+
 (define-public r-sushi
   (package
     (name "r-sushi")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2a6ac38505..76236929de 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10596,33 +10596,6 @@ of @dfn{quantitative trait loci} (QTL) archives, such as eQTL, mQTL, dsQTL,
 and more.")
     (license license:artistic2.0)))
 
-(define-public r-snpstats
-  (package
-    (name "r-snpstats")
-    (version "1.40.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "snpStats" version))
-       (sha256
-        (base32
-         "1298a71swwav53yf9kfqkdpach3818plqcbw0lgb6sibs8y8ff24"))))
-    (properties `((upstream-name . "snpStats")))
-    (build-system r-build-system)
-    (inputs `(("zlib" ,zlib)))
-    (propagated-inputs
-     `(("r-biocgenerics" ,r-biocgenerics)
-       ("r-matrix" ,r-matrix)
-       ("r-survival" ,r-survival)
-       ("r-zlibbioc" ,r-zlibbioc)))
-    (home-page "https://bioconductor.org/packages/snpStats")
-    (synopsis "Methods for SNP association studies")
-    (description
-     "This package provides classes and statistical methods for large
-@dfn{single-nucleotide polymorphism} (SNP) association studies.  This extends
-the earlier snpMatrix package, allowing for uncertainty in genotypes.")
-    (license license:gpl3)))
-
 (define-public r-dropbead
   (let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
         (revision "2"))