summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-11 23:24:10 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-11 20:17:50 +0000
commit70e18f327e541740339c7b32ef80d6ed3d281d52 (patch)
tree4d982ceb71e1d7cd3bcd26e26ca31ecedf920054 /gnu/packages
parentfc6ca1ed99742654f6e53edd483a5701b133fc61 (diff)
downloadguix-70e18f327e541740339c7b32ef80d6ed3d281d52.tar.gz
gnu: hdparm: Use G-expressions.
* gnu/packages/linux.scm (hdparm)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9c20c09973..724cfafc2d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4695,17 +4695,16 @@ isolation or root privileges.")
                 "14cni5r116k07zqj0565byjhv6gf3ns6hd8jkjl7fn5sxgm5sy3h"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
-       (let ((out (assoc-ref %outputs "out")))
-         (list (string-append "binprefix=" out)
-               (string-append "manprefix=" out)
-               ,(string-append "CC=" (cc-for-target))
-               ;; Let Guix strip the binaries and not break cross-compilation.
-               "STRIP=true"))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))           ; no configure script
-       #:tests? #f))                    ; no test suite
+     (list #:make-flags
+           #~(list (string-append "binprefix=" #$output)
+                   (string-append "manprefix=" #$output)
+                   (string-append "CC=" #$(cc-for-target))
+                   ;; Let Guix strip binaries and not break cross-compilation.
+                   "STRIP=true")
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))     ; no configure script
+           #:tests? #f))                ; no test suite
     (home-page "https://sourceforge.net/projects/hdparm/")
     (synopsis "View and tune ATA disk drive parameters")
     (description