summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-29 18:57:15 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:16 +0100
commita38901c01e3e0e07803ddd74509745b8c24e9e38 (patch)
tree33a1461b543f39d164853d93c2c1261ada617387 /gnu/packages
parentbe398aa2b4ed24e73cb2d6865a2040bb12eae1e4 (diff)
downloadguix-a38901c01e3e0e07803ddd74509745b8c24e9e38.tar.gz
gnu: shellcheck: Drop Haskell libraries.
* gnu/packages/haskell-apps.scm (shellcheck)[arguments]: Add
'remove-libraries phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-apps.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 12a7985116..02dc437abd 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -836,7 +836,10 @@ too slow and you'll get wound up in the scroll and crushed.")
            (lambda* (#:key outputs #:allow-other-keys)
              (install-file "shellcheck.1"
                            (string-append (assoc-ref outputs "out")
-                                          "/share/man/man1/")))))))
+                                          "/share/man/man1/"))))
+         (add-after 'register 'remove-libraries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))))
     (native-inputs
      (list pandoc))
     (inputs