summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-06-09 20:50:11 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-06-09 20:50:11 +0800
commitb22cdf0c4240016ca321639682bc58b0384ea36b (patch)
tree4cc28d68b0d92346d75219d1919dc95eea449490 /gnu/packages
parentbb7cf4f5335370c4a29adc236816851076c0fe61 (diff)
downloadguix-b22cdf0c4240016ca321639682bc58b0384ea36b.tar.gz
gnu: python-paramiko: Update to 2.1.2.
* gnu/packages.scm (python-paramiko, python2-paramiko):
Update to 2.1.2.  Enable tests.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 19ffe729bf..44adcba01e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -533,26 +533,24 @@ John the Ripper).")
 (define-public python-paramiko
   (package
     (name "python-paramiko")
-    (version "1.17.4")
+    (version "2.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "paramiko" version))
        (sha256
         (base32
-         "1rs2qcmskcmq66q6g5al08wa41l9am0fad5r719m8wf91msyylqw"))))
+         "04734n0wy3hxk6rij4fr29in5jmr70nxpc7pqi2ksbjysfz4kbjz"))))
     (build-system python-build-system)
     (arguments
-     '(;; FIXME: One test fails with "EOFError not raised by connect".
-       #:tests? #f))
-       ;; #:phases
-       ;; (modify-phases %standard-phases
-       ;;   (replace 'check
-       ;;     (lambda _
-       ;;       (zero? (system* "python" "test.py")))))))
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "python" "test.py")))))))
     (propagated-inputs
-     `(("python-pycrypto" ,python-pycrypto)
-       ("python-ecdsa" ,python-ecdsa)))
+     `(("python-pyasn1" ,python-pyasn1)
+       ("python-cryptography" ,python-cryptography)))
     (home-page "http://www.paramiko.org/")
     (synopsis "SSHv2 protocol library")
     (description "Paramiko is a python implementation of the SSHv2 protocol,