summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2021-08-31 14:52:57 -0400
committerArun Isaac <arunisaac@systemreboot.net>2021-09-03 02:03:07 +0530
commitbc68f23aadd51527843a75476fa9e3d422e86151 (patch)
tree25dc2fbf5a753e60c5b1463cca0f6d3bf6bb7bef /gnu/packages
parent5ee38c467298091e98fa12be45facdcc63a59a87 (diff)
downloadguix-bc68f23aadd51527843a75476fa9e3d422e86151.tar.gz
gnu: Add emacs-dictionary.
* gnu/packages/emacs-xyz.scm (emacs-dictionary): New variable.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c106e81fa5..030809f5ac 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -102,6 +102,7 @@
 ;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Simon South <simon@simonsouth.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29358,6 +29359,27 @@ shorter than usual, using mostly unprefixed keys.")
 @acronym{CWL, Common Workflow Language} files.")
     (license license:gpl3+)))
 
+(define-public emacs-dictionary
+  (package
+    (name "emacs-dictionary")
+    (version "1.11")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/myrkr/dictionary-el")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zsjbpq0s0xdxd9r541f04bj1khhgzhdlzr0m4p17zjh1zardbpi"))))
+    (build-system emacs-build-system)
+    (home-page "http://www.myrkr.in-berlin.de/dictionary/index.html")
+    (synopsis "Emacs client for dictionary servers")
+    (description "This package provides commands for interacting with a
+dictionary server (as defined by RFC 2229; by default, the public server at
+dict.org) from within Emacs.")
+    (license license:gpl2+)))
+
 (define-public emacs-multitran
   (package
     (name "emacs-multitran")