summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-02-01 22:39:40 -0800
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-08 17:09:07 +0100
commitd6e2b467b88d0f663a941b796b2933ed009fca3f (patch)
treea954cede65140925134f23adbda68b09ee00fe32 /gnu/packages
parent572d01e085709586c4e95863a2302f5c8136dd44 (diff)
downloadguix-d6e2b467b88d0f663a941b796b2933ed009fca3f.tar.gz
gnu: wxwidgets: Remove configure option.
* gnu/packages/wxwidgets.scm (wxwidgets)[arguments]: Remove webviewwebkit
  configure option that prevented webview option from being in build and
  wxconfig feature list. Remove 'use-newer-webkit' phase.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wxwidgets.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 0183e07c31..0a93c30f26 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -120,20 +120,12 @@
                             "--with-sdl"
                             "--enable-gui"
                             "--enable-mediactrl"
-                            "--enable-webview"
-                            "--enable-webviewwebkit")
+                            "--enable-webview")
       #:make-flags
       #~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
       #:tests? #f                       ;TODO
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'use-newer-webkit
-            (lambda _
-              ;; XXX: The configure script tests only for an ancient
-              ;; WebKitGTK version.
-              (substitute* "configure"
-                (("webkit2gtk-4\\.0")
-                 "webkit2gtk-4.1"))))
           (add-after 'unpack 'refer-to-inputs
             (lambda* (#:key inputs #:allow-other-keys)
               (let ((catch (search-input-file inputs "include/catch.hpp"))