summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-06-27 12:46:55 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-06-27 12:46:55 +0300
commitd8a046d560e8e149e903b7d3648c7218bf17c085 (patch)
tree72b6d9b386f567c983bc2d65562a55e9ee8485da /gnu/packages
parentace3e549737e7bd935bebeb69b13087d8f0ccd6d (diff)
downloadguix-d8a046d560e8e149e903b7d3648c7218bf17c085.tar.gz
gnu: Add jc.
* gnu/packages/admin.scm (jc): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9212401c40..9d9fd2d95d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -124,6 +124,7 @@
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ruby)
+  #:use-module (gnu packages serialization)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages terminals)
@@ -3864,6 +3865,30 @@ supports.  It can also mount encrypted LUKS volumes using the password
 supplied by the user when logging in.")
     (license (list license:gpl2+ license:lgpl2.1+))))
 
+(define-public jc
+  (package
+    (name "jc")
+    (version "1.11.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/kellyjonbrazil/jc.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0rkckbgm04ql4r48wjgljfiqvsz36n99yqcpcyna8lvlm8h4nmwa"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-ruamel.yaml" ,python-ruamel.yaml)
+       ("python-xmltodict" ,python-xmltodict)
+       ("python-pygments" ,python-pygments)))
+    (home-page "https://github.com/kellyjonbrazil/jc")
+    (synopsis "Convert the output of command-line tools to JSON")
+    (description "@code{jc} JSONifies the output of many CLI tools and
+file-types for easier parsing in scripts.")
+    (license license:expat)))
+
 (define-public jtbl
   (package
     (name "jtbl")