summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJai Vetrivelan <jaivetrivelan@gmail.com>2022-03-05 18:52:40 +0530
committerLudovic Courtès <ludo@gnu.org>2022-03-16 15:48:52 +0100
commitf1aa1f3412169bf1eeee2f90adc426f766d79d3c (patch)
tree5653b7d7022731d9d890aebc9c9ff126710d79c0 /gnu/packages
parent4ba792fa157753ebbc1ecb49740930d83db8ea2a (diff)
downloadguix-f1aa1f3412169bf1eeee2f90adc426f766d79d3c.tar.gz
gnu: dunst: Update to 1.8.1.
* gnu/packages/dunst.scm (dunst): Update to 1.8.1.
* gnu/packages/patches/dunst-1.7.3-fix-crash.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dunst.scm6
-rw-r--r--gnu/packages/patches/dunst-1.7.3-fix-crash.patch21
2 files changed, 3 insertions, 24 deletions
diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
index 7446c3689a..35df682d46 100644
--- a/gnu/packages/dunst.scm
+++ b/gnu/packages/dunst.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,7 +41,7 @@
 (define-public dunst
   (package
     (name "dunst")
-    (version "1.7.3")
+    (version "1.8.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -49,8 +50,7 @@
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ra0ii805w3rrs0qqbjxzl6i79ksz42lnvbglw18h4igkza21kzj"))
-              (patches (search-patches "dunst-1.7.3-fix-crash.patch"))))
+                "19bh5789whlc0n5wbyx3yx8px93hccn42f1p6i1dz96hdkk5mjb8"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no check target
diff --git a/gnu/packages/patches/dunst-1.7.3-fix-crash.patch b/gnu/packages/patches/dunst-1.7.3-fix-crash.patch
deleted file mode 100644
index 8b51d820a4..0000000000
--- a/gnu/packages/patches/dunst-1.7.3-fix-crash.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Author: Danny Milosavljevic <dannym@scratchpost.org>
-Date: 2022-02-04 21:52:05 CET
-
-Fix crash if notification contains invalid pixbuf data.
-
-diff -ru /gnu/store/5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c 5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c
---- /gnu/store/5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c	1970-01-01 01:00:01.000000000 +0100
-+++ 5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c	2022-02-04 19:05:57.534906600 +0100
-@@ -359,8 +359,10 @@
-         g_clear_pointer(&n->icon_id, g_free);
- 
-         GdkPixbuf *icon = icon_get_for_data(new_icon, &n->icon_id, draw_get_scale());
--        n->icon = gdk_pixbuf_to_cairo_surface(icon);
--        g_object_unref(icon);
-+        if (icon) {
-+	        n->icon = gdk_pixbuf_to_cairo_surface(icon);
-+	        g_object_unref(icon);
-+        }
- }
- 
- /* see notification.h */