summary refs log tree commit diff
path: root/gnu/services/avahi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/services/avahi.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations,
as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and
12964df69a99de6190422c752fef65ef813f3b6b respectively.

4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it
cannot currently be tested.

 Conflicts:
	gnu/local.mk
	gnu/packages/aidc.scm
	gnu/packages/boost.scm
	gnu/packages/curl.scm
	gnu/packages/nettle.scm
	gnu/packages/networking.scm
	gnu/packages/python-xyz.scm
	gnu/packages/tls.scm
Diffstat (limited to 'gnu/services/avahi.scm')
-rw-r--r--gnu/services/avahi.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/services/avahi.scm b/gnu/services/avahi.scm
index 7812191cb2..2dcf1d9c1b 100644
--- a/gnu/services/avahi.scm
+++ b/gnu/services/avahi.scm
@@ -40,7 +40,6 @@
             avahi-configuration-wide-area?
             avahi-configuration-domains-to-browse
 
-            avahi-service
             avahi-service-type))
 
 ;;; Commentary:
@@ -166,38 +165,4 @@ service switch (NSS) with support for @code{.local} host name resolution.")
                                             avahi-package)))
                   (default-value (avahi-configuration)))))
 
-(define-deprecated (avahi-service #:key (avahi avahi) debug?
-                                  host-name
-                                  (publish? #t)
-                                  (ipv4? #t) (ipv6? #t)
-                                  wide-area?
-                                  (domains-to-browse '()))
-  avahi-service-type
-  "Return a service that runs @command{avahi-daemon}, a system-wide
-mDNS/DNS-SD responder that allows for service discovery and
-\"zero-configuration\" host name lookups (see @uref{https://avahi.org/}), and
-extends the name service cache daemon (nscd) so that it can resolve
-@code{.local} host names using
-@uref{http://0pointer.de/lennart/projects/nss-mdns/, nss-mdns}.  Additionally,
-add the @var{avahi} package to the system profile so that commands such as
-@command{avahi-browse} are directly usable.
-
-If @var{host-name} is different from @code{#f}, use that as the host name to
-publish for this machine; otherwise, use the machine's actual host name.
-
-When @var{publish?} is true, publishing of host names and services is allowed;
-in particular, avahi-daemon will publish the machine's host name and IP
-address via mDNS on the local network.
-
-When @var{wide-area?} is true, DNS-SD over unicast DNS is enabled.
-
-Boolean values @var{ipv4?} and @var{ipv6?} determine whether to use IPv4/IPv6
-sockets."
-  (service avahi-service-type
-           (avahi-configuration
-            (avahi avahi) (debug? debug?) (host-name host-name)
-            (publish? publish?) (ipv4? ipv4?) (ipv6? ipv6?)
-            (wide-area? wide-area?)
-            (domains-to-browse domains-to-browse))))
-
 ;;; avahi.scm ends here