summary refs log tree commit diff
path: root/gnu/services/base.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-28 16:33:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-29 14:27:22 +0200
commit3a8bfebed94ba295432da8304b7ffb4a611ef761 (patch)
treed2f2fe3214de0a36d5ebddbd2ab51540a0d19358 /gnu/services/base.scm
parent70d6ec3e4facb2eed4b8842031ebd2683a8cfd3b (diff)
downloadguix-3a8bfebed94ba295432da8304b7ffb4a611ef761.tar.gz
etc: Remove hydra.gnu.org.pub key.
* etc/substitutes/hydra.gnu.org.pub: Delete file.
* guix/self.scm (miscellaneous-files): Don't install it.
* Makefile.am (dist_pkgdata_DATA): Remove it.
* gnu/services/base.scm (%default-authorized-guix-keys): Likewise.
(hydra-key-authorization): Rename to…
(substitute-key-authorization): …this.  Adjust only call site.
Diffstat (limited to 'gnu/services/base.scm')
-rw-r--r--gnu/services/base.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 3c1827fb70..537d30add5 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -1533,7 +1533,7 @@ GID."
     (('gnu rest ...) #t)
     (rest #f)))
 
-(define (hydra-key-authorization keys guix)
+(define (substitute-key-authorization keys guix)
   "Return a gexp with code to register KEYS, a list of files containing 'guix
 archive' public keys, with GUIX."
   (define default-acl
@@ -1570,8 +1570,7 @@ archive' public keys, with GUIX."
 
 (define %default-authorized-guix-keys
   ;; List of authorized substitute keys.
-  (list (file-append guix "/share/guix/hydra.gnu.org.pub")
-        (file-append guix "/share/guix/berlin.guixsd.org.pub")))
+  (list (file-append guix "/share/guix/berlin.guixsd.org.pub")))
 
 (define-record-type* <guix-configuration>
   guix-configuration make-guix-configuration
@@ -1688,7 +1687,7 @@ archive' public keys, with GUIX."
 
      ;; Optionally authorize substitute server keys.
      (if authorize-key?
-         (hydra-key-authorization keys guix)
+         (substitute-key-authorization keys guix)
          #~#f))))
 
 (define* (references-file item #:optional (name "references"))