summary refs log tree commit diff
path: root/gnu/services/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
commit9dea3f101f252331c049c03f501398a5ec837ba9 (patch)
tree61d683a9fae3e147332d07fef207c1ddf51fc301 /gnu/services/cups.scm
parent7f0af119a1e3ea9d0ae53811b619437b3e942702 (diff)
parent620669fd17306c2edb21c64a99fa47160fefb319 (diff)
downloadguix-9dea3f101f252331c049c03f501398a5ec837ba9.tar.gz
Merge branch 'master' into core-updates
Conflicts:
	gnu/packages/cups.scm
	gnu/packages/python-web.scm
	gnu/packages/web.scm
	guix/build/maven/pom.scm
Diffstat (limited to 'gnu/services/cups.scm')
-rw-r--r--gnu/services/cups.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 13657e36a7..3caa954579 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -292,11 +292,12 @@ methods.  Otherwise apply to only the listed methods.")
    "Name of the policy.")
   (job-private-access
    (string "@OWNER @SYSTEM")
-   "Specifies an access list for a job's private values.  @code{@@ACL} maps to
-the printer's requesting-user-name-allowed or requesting-user-name-denied
-values.  @code{@@OWNER} maps to the job's owner.  @code{@@SYSTEM} maps to the
-groups listed for the @code{system-group} field of the @code{files-config}
-configuration, which is reified into the @code{cups-files.conf(5)} file.
+   "Specifies an access list for a job's private values.
+@code{@@ACL} maps to the printer's requesting-user-name-allowed or
+requesting-user-name-denied values.  @code{@@OWNER} maps to the job's owner.
+@code{@@SYSTEM} maps to the groups listed for the @code{system-group} field of
+the @code{files-configuration}, which is reified into the
+@code{cups-files.conf(5)} file.
 Other possible elements of the access list include specific user names, and
 @code{@@@var{group}} to indicate members of a specific group.  The access list
 may also be simply @code{all} or @code{default}.")
@@ -312,11 +313,11 @@ may also be simply @code{all} or @code{default}.")
 @code{@@ACL} maps to the printer's requesting-user-name-allowed or
 requesting-user-name-denied values.  @code{@@OWNER} maps to the job's owner.
 @code{@@SYSTEM} maps to the groups listed for the @code{system-group} field of
-the @code{files-config} configuration, which is reified into the
-@code{cups-files.conf(5)} file.  Other possible elements of the access list
-include specific user names, and @code{@@@var{group}} to indicate members of a
-specific group.  The access list may also be simply @code{all} or
-@code{default}.")
+the @code{files-configuration}, which is reified into the
+@code{cups-files.conf(5)} file.
+Other possible elements of the access list include specific user names, and
+@code{@@@var{group}} to indicate members of a specific group.  The access list
+may also be simply @code{all} or @code{default}.")
   (subscription-private-values
    (string (string-join '("notify-events" "notify-pull-method"
                           "notify-recipient-uri" "notify-subscriber-user-name"
@@ -617,9 +618,6 @@ policy is @code{retry-job} or @code{retry-current-job}.")
   (keep-alive?
    (boolean #t)
    "Specifies whether to support HTTP keep-alive connections.")
-  (keep-alive-timeout
-   (non-negative-integer 30)
-   "Specifies how long an idle client connection remains open, in seconds.")
   (limit-request-body
    (non-negative-integer 0)
    "Specifies the maximum size of print files, IPP requests, and HTML form