summary refs log tree commit diff
path: root/gnu/services/telephony.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 20:45:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-08 09:36:26 -0500
commitaef75942fc24fdb753978848b5471c5da21f23b7 (patch)
treea29b651d3d4092ad7be5c7e80c19d94f2963fb39 /gnu/services/telephony.scm
parentc0106ea5c9f783da0b982bbf18ae81ad8065d7b7 (diff)
downloadguix-aef75942fc24fdb753978848b5471c5da21f23b7.tar.gz
gnu: libjami: Move jamid daemon to a "bin" output.
* gnu/packages/jami.scm (libjami) [outputs]: Add a "bin" output.
[arguments]: Add a move-jamid phase.
* gnu/services/telephony.scm
(jami-configuration->command-line-arguments): Refer to the "bin" output of
libjami.
(jami-shepherd-services): Likewise.
Diffstat (limited to 'gnu/services/telephony.scm')
-rw-r--r--gnu/services/telephony.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/services/telephony.scm b/gnu/services/telephony.scm
index b66c7a8563..23ccb8d403 100644
--- a/gnu/services/telephony.scm
+++ b/gnu/services/telephony.scm
@@ -267,7 +267,7 @@ consistent state."))
 CONFIG, a <jami-configuration> object."
   (match-record config <jami-configuration>
     (libjami dbus enable-logging? debug? auto-answer?)
-    `(,(file-append libjami "/libexec/jamid")
+    `(,#~(string-append #$libjami:bin "/libexec/jamid")
       "--persistent"                    ;stay alive after client quits
       ,@(if enable-logging?
             '()                         ;logs go to syslog by default
@@ -524,7 +524,8 @@ argument, either a registered username or the fingerprint of the account.")
                    #:environment-variables
                    ;; This is so that the cx.ring.Ring service D-Bus
                    ;; definition is found by dbus-daemon.
-                   (list (string-append "XDG_DATA_DIRS=" #$libjami "/share"))))
+                   (list (string-append "XDG_DATA_DIRS="
+                                        #$libjami:bin "/share"))))
                (stop #~(make-kill-destructor)))
 
               (shepherd-service
@@ -595,7 +596,8 @@ argument, either a registered username or the fingerprint of the account.")
                     ;; Start the daemon.
                     (define daemon-pid
                       ((make-forkexec-constructor/container
-                        '#$(jami-configuration->command-line-arguments config)
+                        (list #$@(jami-configuration->command-line-arguments
+                                  config))
                         #:mappings
                         (list (file-system-mapping
                                (source "/dev/log") ;for syslog