summary refs log tree commit diff
path: root/gnu/services/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-11-15 17:23:08 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-15 17:55:50 +0100
commit21332f3b8cb8f407a89cdfe7d0460a9947675872 (patch)
tree92614af234e86663e8b2fe76e534d37b05848635 /gnu/services/web.scm
parent782e9975dc11e614fe38f9899806b968f9cd7d70 (diff)
downloadguix-21332f3b8cb8f407a89cdfe7d0460a9947675872.tar.gz
gnu: hpcguix-web: Update to 0.2.0.
* gnu/packages/web.scm (hpcguix-web): Update to 0.2.0.
[arguments]: In 'wrap-program' phase, add guile-zlib to DEPS.
[native-inputs]: Add GUILE.
[inputs]: Add GUILE-ZLIB, GUILE-COMMONMARK, and GUILE-JSON.
[propagated-inputs]: Remove.  These were pointless.
* gnu/services/web.scm (<hpcguix-web-configuration>)[address, port]: New
fields.
* doc/guix.texi (Web Services): Document them.
* gnu/tests/web.scm (%hpcguix-web-os): Add 'address'.
Diffstat (limited to 'gnu/services/web.scm')
-rw-r--r--gnu/services/web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index bb42eacf83..f1c3a2f75e 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -1110,7 +1110,9 @@ a webserver.")
   (package  hpcguix-web-package (default hpcguix-web)) ;<package>
 
   ;; Specs is gexp of hpcguix-web configuration file
-  (specs    hpcguix-web-configuration-specs))
+  (specs    hpcguix-web-configuration-specs)
+  (address  hpcguix-web-configuration-address (default "127.0.0.1"))
+  (port     hpcguix-web-configuration-port (default 5000)))
 
 (define %hpcguix-web-accounts
   (list (user-group
@@ -1163,6 +1165,12 @@ a webserver.")
        (requirement   '(networking))
        (start #~(make-forkexec-constructor
                  (list #$(file-append hpcguix-web "/bin/hpcguix-web")
+                       (string-append "--listen="
+                                      #$(hpcguix-web-configuration-address
+                                         config))
+                       "-p"
+                       #$(number->string
+                          (hpcguix-web-configuration-port config))
                        (string-append "--config="
                                       #$(scheme-file "hpcguix-web.scm" specs)))
                  #:user "hpcguix-web"