summary refs log tree commit diff
path: root/gnu/services
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-10-25 09:40:59 +0200
committerAndreas Enge <andreas@enge.fr>2024-10-28 10:41:27 +0100
commit351fdf69f737d09d24499d6c1ff70a2325fff0fa (patch)
tree1cca5cc5d0dbb834d0a0d2926767a11d8382f2b6 /gnu/services
parent5034f2d45c2a307ebaad6e99957f3b3a4d8cdd0a (diff)
downloadguix-351fdf69f737d09d24499d6c1ff70a2325fff0fa.tar.gz
gnu: postgresql: Deprecate unsupported versions.
Versions 10 and 11 are unsupported according to
https://www.postgresql.org/support/versioning/

postgresql-10 also has a CVE.

* doc/guix.texi: Change default value of postgresql-service-type's
postgresql field.
* gnu/packages/databases.scm (postresql-10, postgresql-11): Use
define-deprecated/public to warn users.
* gnu/services/databases.scm (postgresql-configuration): Change the
default value of postgresql-configuration-postgresql.
* gnu/tests/guix.scm (%guix-data-service-os): Change the default value
of postgresql.

Signed-off-by: Andreas Enge <andreas@enge.fr>
Change-Id: Ie8744c8e1f246e9b45ff5e29d4e98214de3ca66a
Diffstat (limited to 'gnu/services')
-rw-r--r--gnu/services/databases.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/services/databases.scm b/gnu/services/databases.scm
index fa332d7978..0933eb5e79 100644
--- a/gnu/services/databases.scm
+++ b/gnu/services/databases.scm
@@ -168,7 +168,7 @@ host	all	all	::1/128 	md5"))
   postgresql-configuration make-postgresql-configuration
   postgresql-configuration?
   (postgresql         postgresql-configuration-postgresql ;file-like
-                      (default postgresql-10))
+                      (default postgresql))
   (port               postgresql-configuration-port
                       (default 5432))
   (locale             postgresql-configuration-locale