summary refs log tree commit diff
path: root/gnu/services
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-21 20:40:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-28 21:07:47 -0400
commite8f4e1808563eb3c1cd28d419a1f349412af4a0d (patch)
treef9fcb9c939d35ffd193736dd1f76eb090be6f517 /gnu/services
parent39fe13ee2675f062e53f4cbc114ff5d5248cb9b1 (diff)
downloadguix-e8f4e1808563eb3c1cd28d419a1f349412af4a0d.tar.gz
gnu: polkit-mozjs: Rename to polkit and remove obsolete polkit-duktape.
Polkit 121 now uses duktape as the default JavaScript engine.

* gnu/packages/polkit.scm (polkit-mozjs): Rename to...
(polkit): ... this.
[import-modules, modules]: New arguments.
[configure-flags]: Drop non-default "js_engine=mozjs" option.
[phases]{adjust-install-time-etc-directory, patch-bash}: New phases.
{check}: New override.
[inputs]: Replace mozjs-91 with duktape.
[native-inputs]: Add python, python-dbusmock and tini.
(polkit-duktape): Delete variable.
(polkit-for-system): Delete procedure.
(polkit) Delete syntax.
* gnu/services/dbus.scm (%default-polkit): Delete variable.
(<polkit-configuration>): Adjust accordingly.
Diffstat (limited to 'gnu/services')
-rw-r--r--gnu/services/dbus.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/services/dbus.scm b/gnu/services/dbus.scm
index 52cb1e3a51..e4c719fe71 100644
--- a/gnu/services/dbus.scm
+++ b/gnu/services/dbus.scm
@@ -317,19 +317,10 @@ tuples, are all set as environment variables when the bus daemon launches it."
   polkit-configuration make-polkit-configuration
   polkit-configuration?
   (polkit   polkit-configuration-polkit           ;file-like
-            (default %default-polkit))
+            (default polkit))
   (actions  polkit-configuration-actions          ;list of file-like
             (default '())))
 
-(define %default-polkit
-  ;; The default polkit package.
-  (let-system (system target)
-    ;; Since mozjs depends on Rust, which is currently x86_64-only, use
-    ;; polkit-duktape on other systems.
-    (if (string-prefix? "x86_64-" (or target system))
-        polkit-mozjs
-        polkit-duktape)))
-
 (define %polkit-accounts
   (list (user-group (name "polkitd") (system? #t))
         (user-account