summary refs log tree commit diff
path: root/gnu/services
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-01-06 16:40:32 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-01-08 20:43:35 +0800
commit693b52df68a5fac6683c9a77dcb08ee3364aa225 (patch)
treedd24c5bf0d0c5de6d8503ea7a0548f45bbfda28a /gnu/services
parentc8cee2ef96b93079d3c629f52a6779d68348227e (diff)
downloadguix-693b52df68a5fac6683c9a77dcb08ee3364aa225.tar.gz
gnu: services: Add darkstat service.
* gnu/services/monitoring.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* doc/guix.texi (Monitoring Services): Document it.
Diffstat (limited to 'gnu/services')
-rw-r--r--gnu/services/monitoring.scm91
1 files changed, 91 insertions, 0 deletions
diff --git a/gnu/services/monitoring.scm b/gnu/services/monitoring.scm
new file mode 100644
index 0000000000..49a65db4b5
--- /dev/null
+++ b/gnu/services/monitoring.scm
@@ -0,0 +1,91 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services monitoring)
+  #:use-module (gnu services)
+  #:use-module (gnu services shepherd)
+  #:use-module (gnu packages admin)
+  #:use-module (gnu packages monitoring)
+  #:use-module (gnu system shadow)
+  #:use-module (guix gexp)
+  #:use-module (guix records)
+  #:use-module (ice-9 match)
+  #:export (darkstat-configuration
+            darkstat-service-type))
+
+
+;;;
+;;; darkstat
+;;;
+
+(define-record-type* <darkstat-configuration>
+  darkstat-configuration make-darkstat-configuration darkstat-configuration?
+  (package      darkstat-configuration-package
+                (default darkstat))
+  (interface    darkstat-configuration-interface)
+  (port         darkstat-configuration-port
+                (default "667"))
+  (bind-address darkstat-configuration-bind-address
+                (default "127.0.0.1"))
+  (base         darkstat-configuration-base
+                (default "/")))
+
+(define %darkstat-accounts
+  (list (user-account
+         (name "darkstat")
+         (group "darkstat")
+         (system? #t)
+         (comment "darkstat daemon user")
+         (home-directory "/var/lib/darkstat")
+         (shell (file-append shadow "/sbin/nologin")))
+        (user-group
+         (name "darkstat")
+         (system? #t))))
+
+(define darkstat-shepherd-service
+  (match-lambda
+    (($ <darkstat-configuration>
+        package interface port bind-address base)
+     (shepherd-service
+      (documentation "Network statistics gatherer.")
+      (provision '(darkstat))
+      (requirement '(networking))
+      (start #~(make-forkexec-constructor
+                (list #$(file-append package "/sbin/darkstat")
+                      "-i" #$interface
+                      "-p" #$port
+                      "-b" #$bind-address
+                      "--base" #$base
+                      "--syslog" "--no-daemon"
+                      "--chroot" "/var/lib/darkstat"
+                      "--user" "darkstat"
+                      "--import" "darkstat.db"
+                      "--export" "darkstat.db")))
+      (stop #~(make-kill-destructor))))))
+
+(define darkstat-service-type
+  (service-type
+   (name 'darkstat)
+   (description
+    "Run @command{darkstat} to serve network traffic statictics reports over
+HTTP.")
+   (extensions
+    (list (service-extension account-service-type
+                             (const %darkstat-accounts))
+          (service-extension shepherd-root-service-type
+                             (compose list darkstat-shepherd-service))))))