summary refs log tree commit diff
path: root/gnu/services
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-12 22:17:03 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-06-08 14:26:14 +0200
commitf9c04580bf5462bb088f47ad8fc6c3136649cbd6 (patch)
treedae3f6ff15be4e0a0a85dc49ce6078895b4b8cd7 /gnu/services
parent97c94fc2c210341edc5099856c5c0e83cfc0bd86 (diff)
downloadguix-f9c04580bf5462bb088f47ad8fc6c3136649cbd6.tar.gz
services: Add `hurd-console-service-type'.
* gnu/services/hurd.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* doc/guix.texi (Hurd Services): Document it.
Diffstat (limited to 'gnu/services')
-rw-r--r--gnu/services/hurd.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnu/services/hurd.scm b/gnu/services/hurd.scm
new file mode 100644
index 0000000000..36da8e218f
--- /dev/null
+++ b/gnu/services/hurd.scm
@@ -0,0 +1,73 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services hurd)
+  #:use-module (gnu packages admin)
+  #:use-module (gnu packages hurd)
+  #:use-module (gnu services)
+  #:use-module (gnu services shepherd)
+  #:use-module (gnu system)
+  #:use-module (guix gexp)
+  #:use-module (guix records)
+  #:export (hurd-console-configuration
+            hurd-console-service-type))
+
+;;; Commentary:
+;;;
+;;; This module implements services for the Hurd.
+;;;
+;;; Code:
+
+;;;
+;;; The Hurd VGA console service.
+;;;
+
+(define-record-type* <hurd-console-configuration>
+  hurd-console-configuration make-hurd-console-configuration
+  hurd-console-configuration?
+  (hurd   hurd-console-configuration-hurd ;package
+          (default hurd)))
+
+(define (hurd-console-shepherd-service config)
+  "Return a <shepherd-service> for a Hurd VGA console with CONFIG."
+
+  (define console-command
+    #~(list
+       (string-append #$(hurd-console-configuration-hurd config) "/bin/console")
+       "-c" "/dev/vcs"
+       "-d" "vga"
+       "-d" "pc_kbd"
+       "-d" "generic_speaker"))
+
+  (list (shepherd-service
+         (documentation "Run the Hurd’s VGA console client.")
+         (provision '(console))
+         (requirement '(user-processes))
+         (start #~(make-forkexec-constructor #$console-command))
+         (stop #~(make-kill-destructor)))))
+
+(define hurd-console-service-type
+  (service-type
+   (name 'console)
+   (description "Run the Hurd console client.")
+   (extensions
+    (list (service-extension shepherd-root-service-type
+                             hurd-console-shepherd-service)))
+   (default-value (hurd-console-configuration))))
+
+;;; hurd.scm ends here