summary refs log tree commit diff
path: root/gnu/system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-02 18:17:30 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-02 21:16:59 +0100
commit400ed6acdd275f1135aad520baa7379eb6b8cff6 (patch)
treeccb48ae941e2e96b0ea47ccc4677f26a8e7a12ed /gnu/system.scm
parent81fc64da7e9fa5eed782d0c52ebd5c76598e045a (diff)
downloadguix-400ed6acdd275f1135aad520baa7379eb6b8cff6.tar.gz
gnu: eudev: Add variant that depends on libblkid.
This fixes a bug whereby /dev/disk/by-{label,id} would be missing on
GuixSD (/dev/disk/by-id would still contain device-mapped partitions
though.)

Reported by Mark H Weaver <mhw@netris.org>.

* gnu/packages/linux.scm (eudev-with-blkid): New variable.
* gnu/services/base.scm (udev-service): #:udev defaults to
EUDEV-WITH-BLKID.
* gnu/system.scm (%base-packages): Replace EUDEV with EUDEV-WITH-BLKID.
Diffstat (limited to 'gnu/system.scm')
-rw-r--r--gnu/system.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/system.scm b/gnu/system.scm
index 76a9f1ffa3..dea7d882a8 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -371,7 +371,7 @@ explicitly appear in OS."
 
          ;; Get 'insmod' & co. from kmod, not module-init-tools, since udev
          ;; already depends on it anyway.
-         kmod eudev
+         kmod eudev-with-blkid
 
          e2fsprogs kbd