summary refs log tree commit diff
path: root/gnu/system/examples
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-13 17:15:10 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-06-08 13:51:19 +0200
commit59bcffa314171294278444aad4b7012abe50257a (patch)
treefb3da83f672c4c08d7af60950a47d96cae5d16f7 /gnu/system/examples
parente6cd8581c192f739712013874dfa9690522ea9f1 (diff)
downloadguix-59bcffa314171294278444aad4b7012abe50257a.tar.gz
system: examples: Add bare-hurd.tmpl.
* gnu/system/hurd.scm (%hurd-def%hurd-default-operating-system-kernel,
%hurd-default-operating-system): New exported variables.
* gnu/system/examples/bare-hurd.tmpl: New file.
* Makefile.am (EXAMPLES): Add it.
* tests/guix-system.sh: Add --target=i586-pc-gnu when testing it.
Diffstat (limited to 'gnu/system/examples')
-rw-r--r--gnu/system/examples/bare-hurd.tmpl31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/system/examples/bare-hurd.tmpl b/gnu/system/examples/bare-hurd.tmpl
new file mode 100644
index 0000000000..16f20416aa
--- /dev/null
+++ b/gnu/system/examples/bare-hurd.tmpl
@@ -0,0 +1,31 @@
+;; -*-scheme-*-
+
+;; This is an operating system configuration template
+;; for a "bare bones" setup, with no X11 display server.
+
+;; To build a disk image for a virtual machine, do
+;;
+;;     ./pre-inst-env guix system disk-image --target=i586-pc-gnu --no-grafts \
+;;         gnu/system/examples/bare-hurd.tmpl
+;;
+;; it boots, but needs activation, more setup and services to be useful.
+
+(use-modules (gnu) (gnu system hurd) (guix utils))
+
+(define %hurd-os
+  (operating-system
+    (inherit %hurd-default-operating-system)
+    (bootloader (bootloader-configuration
+                 (bootloader grub-minimal-bootloader)
+                 (target "/dev/sdX")))
+    (file-systems (cons (file-system
+                          (device (file-system-label "my-root"))
+                          (mount-point "/")
+                          (type "ext2"))
+                        %base-file-systems))
+    (host-name "guixygnu")
+    (timezone "Europe/Amsterdam")
+    (packages %base-packages/hurd)
+    (services %base-services/hurd)))
+
+%hurd-os