summary refs log tree commit diff
path: root/gnu/system/image.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-10-05 11:07:53 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-10-05 11:16:47 +0200
commit599954c1377a4fc8936f7f341a678ecb9579a2c6 (patch)
tree9057a3a8eb7da5603252afa5738d7eb1329e722d /gnu/system/image.scm
parentb97b423e3f61c80d5877dadc95b3f316cd61788f (diff)
downloadguix-599954c1377a4fc8936f7f341a678ecb9579a2c6.tar.gz
images: Add pine64 support.
* gnu/system/images/pine64.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* gnu/system/image.scm (arm64-disk-image, arm64-image-type): New variables.
Diffstat (limited to 'gnu/system/image.scm')
-rw-r--r--gnu/system/image.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index 2aa6c2ef13..1b5ceb3553 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -65,12 +65,14 @@
 
             efi-disk-image
             iso9660-image
+            arm64-disk-image
 
             image-with-os
             raw-image-type
             qcow2-image-type
             iso-image-type
             uncompressed-iso-image-type
+            arm64-image-type
 
             image-with-label
             system-image
@@ -123,6 +125,18 @@
            (label "GUIX_IMAGE")
            (flags '(boot)))))))
 
+(define arm64-disk-image
+  (image
+   (format 'disk-image)
+   (target "aarch64-linux-gnu")
+   (partitions
+    (list (partition
+           (inherit root-partition)
+           (offset root-offset))))
+   ;; FIXME: Deleting and creating "/var/run" and "/tmp" on the overlayfs
+   ;; fails.
+   (volatile-root? #f)))
+
 
 ;;;
 ;;; Images types.
@@ -164,6 +178,11 @@ set to the given OS."
                   (compression? #f))
                  <>))))
 
+(define arm64-image-type
+  (image-type
+   (name 'arm)
+   (constructor (cut image-with-os arm64-disk-image <>))))
+
 
 ;;
 ;; Helpers.