summary refs log tree commit diff
path: root/gnu/system/install.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-11-24 12:25:03 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:21 +0100
commita49d633c0c65975263270f5ac0050482ca6a5513 (patch)
tree362e0df559e06cacb31b04fd384344ef789ef0dc /gnu/system/install.scm
parent113bdf6ae1819022d8c0d640b78a37c7d6b52723 (diff)
downloadguix-a49d633c0c65975263270f5ac0050482ca6a5513.tar.gz
installer: Move everything to the build side.
* gnu/installer.scm: Rename to ...
* gnu/installer/record.scm: ... this.
* gnu/installer/build-installer.scm: Move everything to the build side and
rename to gnu/installer.scm.
* gnu/installer/newt.scm: Remove all the gexps and add depencies to newt
modules as this code will only be used on the build side by now.
* gnu/local.mk (GNU_SYSTEM_MODULES): Adapt it,
(dist_installer_DATA): New rule to install installer's aux-files.
* gnu/system/install.scm (%installation-services): Use only
'installer-program' from (gnu installer). The installer is now choosen on the
build side.
* guix/self.scm (*system-modules*): Restore previous behaviour and add all
installer files to #:extra-files field of the scheme-node.
* po/guix/POTFILES.in: Adapt it.
Diffstat (limited to 'gnu/system/install.scm')
-rw-r--r--gnu/system/install.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index aef083506c..880a8be32d 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -28,8 +28,7 @@
   #:use-module (guix store)
   #:use-module (guix monads)
   #:use-module ((guix store) #:select (%store-prefix))
-  #:use-module (gnu installer newt)
-  #:use-module (gnu installer build-installer)
+  #:use-module (gnu installer)
   #:use-module (gnu services dbus)
   #:use-module (gnu services networking)
   #:use-module (gnu services shepherd)
@@ -233,8 +232,7 @@ You have been warned.  Thanks for being so brave.\x1b[0m
           (service kmscon-service-type
                    (kmscon-configuration
                     (virtual-terminal "tty1")
-                    (login-program (installer-program-launcher
-                                    newt-installer))))
+                    (login-program (installer-program))))
 
           (login-service (login-configuration
                           (motd motd)))