summary refs log tree commit diff
path: root/gnu/system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-15 23:37:46 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-15 23:37:46 +0200
commit5ce3defed18c204989dceed64d3434ed9f3f1a92 (patch)
treee26ab1459ba73e9771875bbcc7c785560d3b7245 /gnu/system
parent150e20ddde726abdfe77fa666351738cccb06281 (diff)
downloadguix-5ce3defed18c204989dceed64d3434ed9f3f1a92.tar.gz
system: Add (guix build install) module.
* guix/build/vm.scm (install-grub, evaluate-populate-directive,
  reset-timestamps, register-closure): Move to...
* guix/build/install.scm: ... here.  New file.
* Makefile.am (MODULES): Add it.
* gnu/system/vm.scm (expression->derivation-in-linux-vm): Add (guix
  build install) to #:modules.
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/vm.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 7008c5dab2..58e5416b3e 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -109,6 +109,7 @@ input tuple.  The output file name is when building for SYSTEM."
                                              (env-vars '())
                                              (modules
                                               '((guix build vm)
+                                                (guix build install)
                                                 (guix build linux-initrd)
                                                 (guix build utils)))
                                              (guile-for-build
@@ -179,9 +180,7 @@ made available under the /xchg CIFS share."
                       ;; TODO: Require the "kvm" feature.
                       #:system system
                       #:env-vars env-vars
-                      #:modules `((guix build utils)
-                                  (guix build vm)
-                                  (guix build linux-initrd))
+                      #:modules modules
                       #:guile-for-build guile-for-build
                       #:references-graphs references-graphs)))