summary refs log tree commit diff
path: root/gnu/system
diff options
context:
space:
mode:
authorStefan <stefan-guix@vodafonemail.de>2022-12-01 13:46:38 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-01 14:31:29 -0500
commitc7793b82efd3383a9f7adf0dfa82d71ee032e41b (patch)
tree3e666ff52724e32fe88fbd93721c69259990bfb0 /gnu/system
parent0ea832805290e9ee25d53f14b918dea86e95009a (diff)
downloadguix-c7793b82efd3383a9f7adf0dfa82d71ee032e41b.tar.gz
gnu: raspberry-pi: Add a bootloader-chain for the Raspberry Pi and os examples.
* gnu/packages/raspberry-pi.scm (grub-efi-bootloader-chain-raspi-64): New
bootloader variable, capable to boot a Raspberry Pi over network or from a
local storage.
* gnu/system/examples/raspberry-pi-64.tmpl: New operating-system example.
* gnu/system/examples/raspberry-pi-64-nfs-root.tmpl: New operating-system
example for booting over network.
* Makefile.am (EXAMPLES): Register the new files.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/examples/raspberry-pi-64-nfs-root.tmpl75
-rw-r--r--gnu/system/examples/raspberry-pi-64.tmpl79
2 files changed, 154 insertions, 0 deletions
diff --git a/gnu/system/examples/raspberry-pi-64-nfs-root.tmpl b/gnu/system/examples/raspberry-pi-64-nfs-root.tmpl
new file mode 100644
index 0000000000..7bcac8ded0
--- /dev/null
+++ b/gnu/system/examples/raspberry-pi-64-nfs-root.tmpl
@@ -0,0 +1,75 @@
+;; This is an operating-system configuration template of a
+;; 64-bit minimal system for a Raspberry Pi with an NFS root file-system.
+
+;; It neither installs firmware nor device-tree files for the Raspberry Pi.
+;; It just assumes them to be existing in boot/efi in the same way that some
+;; UEFI firmware with ACPI data is usually assumed to be existing on PCs.
+
+;; It expects the boot/efi directory to be served via TFTP and the root
+;; file-system to be served via NFS. See the grub-efi-netboot-bootloader
+;; description in the manual for more details.
+
+(use-modules (gnu)
+             (gnu artwork)
+             (gnu system nss))
+(use-service-modules admin
+                     avahi
+                     networking
+                     ssh)
+(use-package-modules certs
+                     linux
+                     raspberry-pi
+                     ssh)
+
+(define %my-public-key
+  (local-file (string-append (getenv "HOME") "/.ssh/id_ecdsa.pub")))
+
+(define-public raspberry-pi-64-nfs-root
+  (operating-system
+    (host-name "raspberrypi-guix")
+    (timezone "Europe/Berlin")
+    (bootloader (bootloader-configuration
+                 (bootloader grub-efi-bootloader-chain-raspi-64)
+                 (targets (list "/boot/efi"))
+                 (theme (grub-theme
+                         (resolution '(1920 . 1080))
+                         (image (file-append
+                                 %artwork-repository
+                                 "/grub/GuixSD-fully-black-16-9.svg"))))))
+    (kernel-arguments '("ip=dhcp"))
+    (kernel (customize-linux #:linux linux-libre-arm64-generic
+                             #:extra-version "arm64-generic-netboot"
+                             #:configs '("CONFIG_NFS_SWAP=y"
+                                         "CONFIG_USB_USBNET=y"
+                                         "CONFIG_USB_LAN78XX=y"
+                                         "CONFIG_USB_NET_SMSC95XX=y")))
+    (initrd-modules '())
+    (file-systems (cons* (file-system
+                           (mount-point "/")
+                           (type "nfs")
+                           (device ":/export/raspberrypi/guix")
+                           (options "addr=10.20.30.40,vers=4.1"))
+                         %base-file-systems))
+    (swap-devices (list (swap-space
+                         (target "/run/swapfile"))))
+    (users (cons* (user-account
+                   (name "pi")
+                   (group "users")
+                   (supplementary-groups '("wheel" "netdev" "audio" "video"))
+                   (home-directory "/home/pi"))
+                  %base-user-accounts))
+    (packages (cons* nss-certs
+                     openssh
+                     %base-packages))
+    (services (cons* (service avahi-service-type)
+                     (service dhcp-client-service-type)
+                     (service ntp-service-type)
+                     (service openssh-service-type
+                              (openssh-configuration
+                               (x11-forwarding? #t)
+                               (authorized-keys
+                                `(("pi" ,%my-public-key)))))
+                     %base-services))
+    (name-service-switch %mdns-host-lookup-nss)))
+
+raspberry-pi-64-nfs-root
diff --git a/gnu/system/examples/raspberry-pi-64.tmpl b/gnu/system/examples/raspberry-pi-64.tmpl
new file mode 100644
index 0000000000..7d2638dd80
--- /dev/null
+++ b/gnu/system/examples/raspberry-pi-64.tmpl
@@ -0,0 +1,79 @@
+;; This is an operating-system configuration template of a
+;; 64-bit minimal system for a Raspberry Pi with local storage.
+
+;; It neither installs firmware nor device-tree files for the Raspberry Pi.
+;; It just assumes them to be existing in boot/efi in the same way that some
+;; UEFI firmware with ACPI data is usually assumed to be existing on PCs.
+
+;; It expects the boot-partition to be mounted as boot/efi in the same way
+;; as it is usually expeted on PCs with UEFI firmware.
+
+(use-modules (gnu)
+             (gnu artwork)
+             (gnu system nss))
+(use-service-modules admin
+                     avahi
+                     networking
+                     ssh)
+(use-package-modules certs
+                     linux
+                     raspberry-pi
+                     ssh)
+
+(define %my-public-key
+  (local-file (string-append (getenv "HOME") "/.ssh/id_ecdsa.pub")))
+
+(define-public raspberry-pi-64
+  (operating-system
+    (host-name "raspberrypi-guix")
+    (timezone "Europe/Berlin")
+    (bootloader (bootloader-configuration
+                 (bootloader grub-efi-bootloader-chain-raspi-64)
+                 (targets (list "/boot/efi"))
+                 (theme (grub-theme
+                         (resolution '(1920 . 1080))
+                         (image (file-append
+                                 %artwork-repository
+                                 "/grub/GuixSD-fully-black-16-9.svg"))))))
+    (kernel (customize-linux #:linux linux-libre-arm64-generic
+                             ;; It is possible to use a specific defconfig
+                             ;; file, for example the "bcmrpi3_defconfig" with
+                             ;; the variable shown below.  Unfortunately the
+                             ;; kernel built from the linux-libre sources with
+                             ;; this defconfig file does not boot.
+                             ;;#:extra-version "gnu-bcmrpi3"
+                             ;;#:defconfig %bcmrpi3-defconfig
+                             ))
+    (initrd-modules '())
+    (file-systems (cons* (file-system
+                           (mount-point "/")
+                           (type "ext4")
+                           (device (file-system-label "Guix")))
+                         (file-system
+                           (mount-point "/boot/efi")
+                           (type "vfat")
+                           (device (file-system-label "EFI")))
+                         %base-file-systems))
+    (swap-devices (list (swap-space
+                         (target "/run/swapfile"))))
+    (users (cons* (user-account
+                   (name "pi")
+                   (group "users")
+                   (supplementary-groups '("wheel" "netdev" "audio" "video"))
+                   (home-directory "/home/pi"))
+                  %base-user-accounts))
+    (packages (cons* nss-certs
+                     openssh
+                     %base-packages))
+    (services (cons* (service avahi-service-type)
+                     (service dhcp-client-service-type)
+                     (service ntp-service-type)
+                     (service openssh-service-type
+                              (openssh-configuration
+                               (x11-forwarding? #t)
+                               (authorized-keys
+                                `(("pi" ,%my-public-key)))))
+                     %base-services))
+    (name-service-switch %mdns-host-lookup-nss)))
+
+raspberry-pi-64