summary refs log tree commit diff
path: root/gnu/system
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-24 10:57:39 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-25 07:20:00 +0100
commit1dfe8c372163d481ebebb97dd3b4cafa49906b28 (patch)
treee190d334785ca2097766968e0da85afb03ad2144 /gnu/system
parent14bc88a9b3e467f6d588ecbca3766fa0d126c0a0 (diff)
downloadguix-1dfe8c372163d481ebebb97dd3b4cafa49906b28.tar.gz
gnu: linux-libre: Build simplefb into all x86{,_64} kernels.
This attempts to mitigate <https://issues.guix.gnu.org/52667>.

It makes linux-libre@5.15 consistent with older versions which do not
support a modular simplefb, allowing a single %base-initrd-modules
simple list for all of them.

Unlike CONFIG_FB_SIMPLE=m, CONFIG_FB_SIMPLE=y conflicts with
CONFIG_DRM_SIMPLEDRM, so the latter is now disabled.  Let us hope it is
not missed.

* gnu/packages/aux-files/linux-libre/5.15-i686.conf,
gnu/packages/aux-files/linux-libre/5.15-x86_64.conf:
Unset CONFIG_DRM_SIMPLEDRM to build in CONFIG_FB_SIMPLE=y.
* gnu/system/linux-initrd.scm (default-initrd-modules):
Remove "simplefb".
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/linux-initrd.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/system/linux-initrd.scm b/gnu/system/linux-initrd.scm
index ed94c1de89..c78dd09205 100644
--- a/gnu/system/linux-initrd.scm
+++ b/gnu/system/linux-initrd.scm
@@ -352,7 +352,7 @@ FILE-SYSTEMS."
     "dm-crypt" "xts" "serpent_generic" "wp512" ;for encrypted root partitions
     "nls_iso8859-1"                            ;for `mkfs.fat`, et.al
     ,@(if (string-match "^(x86_64|i[3-6]86)-" system)
-          '("framebuffer_coreboot" "simplefb" ;for display during early boot
+          '("framebuffer_coreboot"       ;for display during early (Core)boot
             "pata_acpi" "pata_atiixp"    ;for ATA controllers
             "isci")                      ;for SAS controllers like Intel C602
           '())