summary refs log tree commit diff
path: root/gnu/system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-13 16:44:02 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-13 23:12:43 +0100
commit59e80445882f8b0379e54916f89510c0deda6698 (patch)
tree2769fffa217f630349c5a7207ee92204af046f9d /gnu/system
parent13f62aef2d87dc888f89fea3260eaa39938e6640 (diff)
downloadguix-59e80445882f8b0379e54916f89510c0deda6698.tar.gz
Remove traces of "GuixSD".
* gnu/bootloader/extlinux.scm (extlinux-configuration-file): Remove
mentions of "GuixSD".
* gnu/bootloader/grub.scm (install-grub-efi): Likewise.
* gnu/build/vm.scm (make-iso9660-image): Change default #:volume-id to
"Guix_image".
(initialize-hard-disk): Search for the "Guix_image" label.
* gnu/ci.scm (system-test-jobs, tarball-jobs): Remove "GuixSD".
* gnu/installer/newt/welcome.scm (run-welcome-page): Likewise.
* gnu/packages/audio.scm (supercollider)[description]: Likewise.
* gnu/packages/curl.scm (curl): Likewise.
* gnu/packages/emacs.scm (emacs): Likewise.
* gnu/packages/gnome.scm (network-manager): Likewise.
* gnu/packages/julia.scm (julia): Likewise.
* gnu/packages/linux.scm (alsa-plugins): Likewise.
(powertop, wireless-regdb): Likewise.
* gnu/packages/package-management.scm (guix): Likewise.
* gnu/packages/polkit.scm (polkit): Likewise.
* gnu/packages/tex.scm (texlive-bin): Likewise.
* gnu/services/base.scm (file-systems->fstab): Likewise.
* gnu/services/cups.scm (%cups-activation): Likewise.
* gnu/services/mail.scm (%dovecot-activation): Likewise.
* gnu/services/messaging.scm (prosody-configuration)[log]: Likewise.
* gnu/system/examples/vm-image.tmpl (vm-image-motd): Likewise.
* gnu/system/install.scm (installation-os)[file-systems]: Change root
file system label to "Guix_image".
* gnu/system/mapped-devices.scm (check-device-initrd-modules):
Remove "GuixSD".
* gnu/system/vm.scm (system-docker-image): Likewise.
(system-disk-image)[root-label]: Change to "Guix_image".
* gnu/tests/install.scm (run-install): Remove "GuixSD".
* guix/modules.scm (guix-module-name?): Likewise.
* nix/libstore/optimise-store.cc: Likewise.
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/examples/vm-image.tmpl2
-rw-r--r--gnu/system/install.scm2
-rw-r--r--gnu/system/mapped-devices.scm4
-rw-r--r--gnu/system/vm.scm6
4 files changed, 7 insertions, 7 deletions
diff --git a/gnu/system/examples/vm-image.tmpl b/gnu/system/examples/vm-image.tmpl
index 4d292c1bc6..6dc67b0901 100644
--- a/gnu/system/examples/vm-image.tmpl
+++ b/gnu/system/examples/vm-image.tmpl
@@ -8,7 +8,7 @@
 (define vm-image-motd (plain-file "motd" "
 This is the GNU system.  Welcome!
 
-This instance of GuixSD is a bare-bones template for virtualized environments.
+This instance of Guix System is a bare-bones template for virtualized environments.
 
 You will probably want to do these things first if you booted in a virtual
 private server (VPS):
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 0ba2066d11..bad318d06b 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -353,7 +353,7 @@ You have been warned.  Thanks for being so brave.\x1b[0m
      ;; the appropriate one.
      (cons* (file-system
               (mount-point "/")
-              (device (file-system-label "GuixSD_image"))
+              (device (file-system-label "Guix_image"))
               (type "ext4"))
 
             ;; Make /tmp a tmpfs instead of keeping the overlayfs.  This
diff --git a/gnu/system/mapped-devices.scm b/gnu/system/mapped-devices.scm
index a874666463..e29ad3ad38 100644
--- a/gnu/system/mapped-devices.scm
+++ b/gnu/system/mapped-devices.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
 ;;;
@@ -120,7 +120,7 @@
 DEVICE must be a \"/dev\" file name."
   (define aliases
     ;; Attempt to load 'modules.alias' from the current kernel, assuming we're
-    ;; on GuixSD, and assuming that corresponds to the kernel we'll be
+    ;; on Guix System, and assuming that corresponds to the kernel we'll be
     ;; installing.  Skip the whole thing if that file cannot be read.
     (catch 'system-error
       (lambda ()
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index e09c687a04..e561285964 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -463,8 +463,8 @@ the image."
   "Build a docker image.  OS is the desired <operating-system>.  NAME is the
 base name to use for the output file.  When REGISTER-CLOSURES? is not #f,
 register the closure of OS with Guix in the resulting Docker image.  This only
-makes sense when you want to build a GuixSD Docker image that has Guix
-installed inside of it.  If you don't need Guix (e.g., your GuixSD Docker
+makes sense when you want to build a Guix System Docker image that has Guix
+installed inside of it.  If you don't need Guix (e.g., your Docker
 image just contains a web server that is started by the Shepherd), then you
 should set REGISTER-CLOSURES? to #f."
   (define schema
@@ -610,7 +610,7 @@ to USB sticks meant to be read-only."
 
   (define root-label
     ;; Volume name of the root file system.
-    (normalize-label "GuixSD_image"))
+    (normalize-label "Guix_image"))
 
   (define root-uuid
     ;; UUID of the root file system, computed in a deterministic fashion.