summary refs log tree commit diff
path: root/gnu/system
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-05-18 17:49:05 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-18 18:35:37 +0200
commit1d86b05618a063378d7ffc89a9b4c33dd65a760c (patch)
tree1507fc79ed5a3966d0a9488da703985017664499 /gnu/system
parent08eafef8650922681bad10d9f5a3f92ff91616b6 (diff)
downloadguix-1d86b05618a063378d7ffc89a9b4c33dd65a760c.tar.gz
vm: Create installation media with MBR and HFS only, no GPT.
* gnu/build/vm.scm (make-iso9660-image): Accept XORRISO,
GRUB-MKRESCUE-ENVIRONMENT.
* gnu/system/vm.scm (iso9660-image): Pass XORRISO; accept
GRUB-MKRESCUE-ENVIRONMENT.
(system-disk-image): Pass GRUB-MKRESCUE-ENVIRONMENT.
* gnu/packages/patches/xorriso-no-mbr-in-inner-efi.patch: New file.
* gnu/packages/patches/xorriso-no-partition-table-in-inner-efi.patch: New
file.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/cdrom.scm (xorriso)[source]: Add patches.
[arguments]<#:phases>[install-frontends]:
Add phase.
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/vm.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index aa37896498..0d4ed63eec 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -266,7 +266,8 @@ made available under the /xchg CIFS share."
                         bootcfg-drv
                         bootloader
                         (register-closures? (has-guix-service-type? os))
-                        (inputs '()))
+                        (inputs '())
+                        (grub-mkrescue-environment '()))
   "Return a bootable, stand-alone iso9660 image.
 
 INPUTS is a list of inputs (as for packages)."
@@ -313,7 +314,9 @@ INPUTS is a list of inputs (as for packages)."
                           inputs)))
 
              (set-path-environment-variable "PATH" '("bin" "sbin") inputs)
-             (make-iso9660-image #$(bootloader-package bootloader)
+             (make-iso9660-image #$xorriso
+                                 '#$grub-mkrescue-environment
+                                 #$(bootloader-package bootloader)
                                  #$bootcfg-drv
                                  #$os
                                  "/xchg/guixsd.iso"
@@ -704,7 +707,9 @@ to USB sticks meant to be read-only."
                        #:bootloader (bootloader-configuration-bootloader
                                      (operating-system-bootloader os))
                        #:inputs `(("system" ,os)
-                                  ("bootcfg" ,bootcfg)))
+                                  ("bootcfg" ,bootcfg))
+                       #:grub-mkrescue-environment
+                       '(("MKRESCUE_SED_MODE" . "mbr_hfs")))
         (qemu-image #:name name
                     #:os os
                     #:bootcfg-drv bootcfg