summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:32:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:49 +0300
commit0083404175a8da57ab165d4517ad743990b27edc (patch)
treee2df39820f92b74bc415d9870d243327c5f83bb0 /gnu
parente2496a814f8ac4b62b91e05fc9899b9bb85b3ac4 (diff)
downloadguix-0083404175a8da57ab165d4517ad743990b27edc.tar.gz
gnu: julia-openspecfun-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-openspecfun-jll): Move to ...
* gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-jll.scm45
-rw-r--r--gnu/packages/julia-xyz.scm49
2 files changed, 46 insertions, 48 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 77216864d7..a403829ff2 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -28,6 +28,7 @@
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages image)
   #:use-module (gnu packages julia)
+  #:use-module (gnu packages maths)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web))
 
@@ -234,3 +235,47 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
     (description "This Julia module provides @code{mbed TLS} libraries and
 wrappers.")
     (license license:expat)))
+
+(define-public julia-openspecfun-jll
+  (let ((commit "6c505cce3bdcd9cd2b15b4f9362ec3a42c4da71c"))
+    (package
+      (name "julia-openspecfun-jll")
+      (version "0.5.3+4")                 ;tag not created upstream
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/OpenSpecFun_jll.jl")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0bl2gcgndsbiwhwy8fl070cjm1fyf9kxj6gkikgirmzgjl29iakn"))))
+      (build-system julia-build-system)
+      (arguments
+       `(#:tests? #f                      ; no runtests.jl
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'override-binary-path
+             (lambda* (#:key inputs #:allow-other-keys)
+               (map
+                (lambda (wrapper)
+                  (substitute* wrapper
+                    (("generate_wrapper_header.*")
+                     (string-append
+                      "generate_wrapper_header(\"OpenSpecFun\", \""
+                      (assoc-ref inputs "openspecfun") "\")\n"))))
+                ;; There's a Julia file for each platform, override them all
+                (find-files "src/wrappers/" "\\.jl$"))
+               #t)))))
+      (inputs
+       `(("openspecfun" ,openspecfun)))
+      (propagated-inputs
+       `(("julia-jllwrappers" ,julia-jllwrappers)
+         ("julia-compilersupportlibraries-jll" ,julia-compilersupportlibraries-jll)))
+      (home-page "https://github.com/JuliaBinaryWrappers/OpenSpecFun_jll.jl")
+      (synopsis "Internal wrappers")
+      (description "This package provides a wrapper for OpenSpecFun.  It is an
+autogenerated source package constructed using @code{BinaryBuilder.jl}. The
+originating @code{build_tarballs.jl} script can be found on the community
+build tree Yggdrasil.")
+      (license license:expat))))
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 397e5e597e..86cb2933f7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -26,8 +26,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
-  #:use-module (gnu packages julia-jll)
-  #:use-module (gnu packages maths))
+  #:use-module (gnu packages julia-jll))
 
 (define-public julia-abstractffts
   (package
@@ -1233,52 +1232,6 @@ have arbitrary indices, similar to those found in some other programming
 languages like Fortran.")
     (license license:expat)))
 
-;;; TODO: Remove this autogenerated source package
-;;; and build it from realse source using <https://github.com/JuliaPackaging/Yggdrasil/>
-(define-public julia-openspecfun-jll
-(let ((commit "6c505cce3bdcd9cd2b15b4f9362ec3a42c4da71c"))
-  (package
-    (name "julia-openspecfun-jll")
-    (version "0.5.3+4")                 ;tag not created upstream
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/JuliaBinaryWrappers/OpenSpecFun_jll.jl")
-             (commit commit)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0bl2gcgndsbiwhwy8fl070cjm1fyf9kxj6gkikgirmzgjl29iakn"))))
-    (build-system julia-build-system)
-    (arguments
-     `(#:tests? #f                      ; no runtests.jl
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'override-binary-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             (map
-              (lambda (wrapper)
-                (substitute* wrapper
-                  (("generate_wrapper_header.*")
-                   (string-append
-                    "generate_wrapper_header(\"OpenSpecFun\", \""
-                    (assoc-ref inputs "openspecfun") "\")\n"))))
-              ;; There's a Julia file for each platform, override them all
-              (find-files "src/wrappers/" "\\.jl$"))
-             #t)))))
-    (inputs
-     `(("openspecfun" ,openspecfun)))
-    (propagated-inputs
-     `(("julia-jllwrappers" ,julia-jllwrappers)
-       ("julia-compilersupportlibraries-jll" ,julia-compilersupportlibraries-jll)))
-    (home-page "https://github.com/JuliaBinaryWrappers/OpenSpecFun_jll.jl")
-    (synopsis "Internal wrappers")
-    (description "This package provides a wrapper for OpenSpecFun.  It is an
-autogenerated source package constructed using @code{BinaryBuilder.jl}. The
-originating @code{build_tarballs.jl} script can be found on the community
-build tree Yggdrasil.")
-    (license license:expat))))
-
 (define-public julia-parameters
   (package
     (name "julia-parameters")