summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 14:48:39 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-20 18:33:50 +0200
commit04b909829c6f7f3cb8bed53ed0f6dbf4896cc771 (patch)
tree90857b38b870e31aac6c738913053c42d18d3e7d /gnu
parentdd32e0ecfeb15502ac78e8226e7d5e62204fb08b (diff)
downloadguix-04b909829c6f7f3cb8bed53ed0f6dbf4896cc771.tar.gz
gnu: ocamlcudf: Fix reference to output.
* gnu/packages/ocaml.scm
  (ocamlcudf)[arguments]<#:make-flags>: Use #$output.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1624823394..c97f633cbe 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -583,10 +583,9 @@ for day to day programming.")
         ("ocaml-ounit" ,ocaml-ounit)))
     (arguments
      `(#:make-flags
-       (list
-         "all" "opt"
-         (string-append "BINDIR=" (assoc-ref %outputs "out")
-                        "/bin"))
+       ,#~(list
+           "all" "opt"
+           (string-append "BINDIR=" #$output "/bin"))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))