summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-08 20:22:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 18:40:46 +0100
commit061ce5500abcaaf67c9e0cf09f8a881525a4fdef (patch)
tree54b30f5fa53e0b27b9899146e63bbd4c0c11e901 /gnu
parent1e5c9bb0d212dc4befb63d05e19c17d7de7e95ad (diff)
downloadguix-061ce5500abcaaf67c9e0cf09f8a881525a4fdef.tar.gz
gnu: Add r-pepsnmr.
* gnu/packages/bioconductor.scm (r-pepsnmr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 66fa69fade..1ceee9d77d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8514,6 +8514,35 @@ classification and ranking tasks.  @dfn{Area under curve} (AUC), precision at
 a given recall, F-score for single and multiple classes are available.")
     (license license:gpl2+)))
 
+(define-public r-pepsnmr
+  (package
+    (name "r-pepsnmr")
+    (version "1.16.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "PepsNMR" version))
+              (sha256
+               (base32
+                "02i29jinawssqlb33wvj0h9w6cfcvamlyfxdynd38jmwx23l15l5"))))
+    (properties `((upstream-name . "PepsNMR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ggplot2
+           r-gridextra
+           r-matrix
+           r-matrixstats
+           r-ptw
+           r-reshape2))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/ManonMartin/PepsNMR")
+    (synopsis "Pre-process 1H-NMR FID signals")
+    (description
+     "This package provides R functions for common pre-processing steps that
+are applied on @acronym{1H-NMR, proton nuclear magnetic resonance} data.  It
+also provides a function to read the @acronym{FID, free induction decay}
+signals directly in the Bruker format.")
+    (license license:gpl2)))
+
 ;; This is a CRAN package, but it depends on a Bioconductor package.
 (define-public r-codedepends
   (package