summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 19:53:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 20:14:15 +0100
commit3a3dd0552837b7c1c0082e3f8932b6a80bee5bc2 (patch)
tree1943ef54e0ed1d795b31a2128219b8e635b56cca /gnu
parentcc13c85c4af0bdf95bd36c6b63b21c70d3a5a319 (diff)
downloadguix-3a3dd0552837b7c1c0082e3f8932b6a80bee5bc2.tar.gz
gnu: Add r-misctools.
* gnu/packages/cran.scm (r-misctools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5665b44f4d..151fc6a0ca 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32343,6 +32343,30 @@ of a small set of carefully designed functions, most of which
 ")
     (license license:gpl3)))
 
+(define-public r-misctools
+  (package
+    (name "r-misctools")
+    (version "0.6-26")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "miscTools" version))
+       (sha256
+        (base32 "16pwfxpyl0zv3hjxx2kjchkg7p6kbj0s2rrpskj7rkhjr9imlg5y"))))
+    (properties `((upstream-name . "miscTools")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-digest))
+    (home-page "http://www.micEcon.org")
+    (synopsis "Miscellaneous tools and utilities")
+    (description
+     "This package provides miscellaneous small tools and utilities.  Many of
+them facilitate the work with matrices, e.g. inserting rows or columns,
+creating symmetric matrices, or checking for semidefiniteness.  Other tools
+facilitate the work with regression models, e.g. extracting the standard
+errors, obtaining the number of (estimated) parameters, or calculating
+R-squared values.")
+    (license license:gpl2+)))
+
 (define-public r-mockery
   (package
     (name "r-mockery")