summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:55 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commit5f5d7716be96bc5378d4bd5ad5f58bb8e297da9e (patch)
tree94150e95ce457182f1f835291fc3f0b505eed071 /gnu
parent5016abc09174edfbe032034a89c1f4cc5d146b16 (diff)
downloadguix-5f5d7716be96bc5378d4bd5ad5f58bb8e297da9e.tar.gz
gnu: Add trytond-stock-supply-day.
* gnu/packages/tryton.scm (trytond-stock-supply-day): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 60dc127edb..3bbd3a6311 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4232,3 +4232,27 @@ mechanisms and introduces the concepts of order point.")
 
 (define-public python-trytond-stock-supply
   (deprecated-package "python-trytond-stock-supply" trytond-stock-supply))
+
+(define-public trytond-stock-supply-day
+  (package
+    (name "trytond-stock-supply-day")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_supply_day" version))
+       (sha256
+        (base32 "1b6q2zk0qnsxdhlqgsnb49prgn6sgqlpr84vy31a2p83mwiz0fqr"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_supply_day"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-purchase" ,trytond-purchase)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-supply-day")
+    (synopsis "Tryton module to add supply weekdays")
+    (description "The @emph{Stock Supply Day} Tryton module adds a Week Days
+list on the Product Supplier form.  This allow to restrict the supply week
+days for each supplier on each product.  If no days are defined for a supplier
+a supplying may happens at any day of the week.")
+    (license license:gpl3+)))