summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:47 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commit6aa1127f88fee3f90a9471670c5fba6203ab4a9d (patch)
tree667ee2501164a7a2358bf1eab3a40236b726d03b /gnu
parent00a81298033937ca9b9f0c686069db29074eb644 (diff)
downloadguix-6aa1127f88fee3f90a9471670c5fba6203ab4a9d.tar.gz
gnu: Add trytond-sale-supply-production.
* gnu/packages/tryton.scm (trytond-sale-supply-production): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index fb927698f7..51857aaff3 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3646,6 +3646,34 @@ customer as Delivery Address; at the confirmation of the purchase a drop
 shipment is created and linked to both the purchase and the sale.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-supply-production
+  (package
+    (name "trytond-sale-supply-production")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_supply_production" version))
+       (sha256
+        (base32 "03v702r4sfmql5yv6414gi2y72psvr3zq3xmx049w5nsywc2585v"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_supply_production"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-production" ,trytond-production)
+       ("trytond-sale-supply" ,trytond-sale-supply)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-sale-supply-production")
+    (synopsis "Tryton module to supply sales from production")
+    (description "The @emph{Sale Supply Production} Tryton module adds a
+\"supply on sale\" option to producible products.  If checked, it will
+generate a production request for each sale line of this product regardless of
+the stock levels.  Once the products are produced they are assigned to the
+customer shipments.  If the production request is cancelled, the sale goes
+back to the default supply method.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")