summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:48:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:50 +0300
commit76cdb2b821ba6bcce36a0c712bf8c90f84f08dd0 (patch)
treeaeab438461719f0dba819c41bbfc70c316ce03ce /gnu
parent4073aeae4635019f5d792338ef9fd3c8fe37b29b (diff)
downloadguix-76cdb2b821ba6bcce36a0c712bf8c90f84f08dd0.tar.gz
gnu: Add julia-bzip2-jll.
* gnu/packages/julia-jll.scm (julia-bzip2-jll): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-jll.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 319b8fd882..05f5d2a811 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -38,6 +38,46 @@
 ;;; TODO: Remove this autogenerated source package
 ;;; and build it from realse source using <https://github.com/JuliaPackaging/Yggdrasil/>
 
+(define-public julia-bzip2-jll
+  (package
+    (name "julia-bzip2-jll")
+    (version "1.0.7+0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaBinaryWrappers/Bzip2_jll.jl")
+             (commit (string-append "Bzip2-v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "188ngx4axdqr55ahv2xssl3cf699l1sxi41j336m9sw8plf4hhk8"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f                      ; No runtests.jl
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+              (lambda (wrapper)
+                (substitute* wrapper
+                  (("generate_wrapper_header.*")
+                   (string-append
+                    "generate_wrapper_header(\"Bzip2\", \""
+                    (assoc-ref inputs "bzip2") "\")\n"))))
+              ;; There's a Julia file for each platform, override them all
+              (find-files "src/wrappers/" "\\.jl$"))
+             #t)))))
+    (inputs
+     `(("bzip2" ,bzip2)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Bzip2_jll.jl")
+    (synopsis "Bzip2 binary wrappers")
+    (description "This Julia module provides a wrapper for the @code{Bzip2}
+compression program.")
+    (license license:expat)))
+
 (define-public julia-compilersupportlibraries-jll
   (package
     (name "julia-compilersupportlibraries-jll")