summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:19 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commit8382a6d8bae23ee83ebcab6253076bcaf18ebcdf (patch)
tree8c5548940c18ab5a5ea3d514d0cf216a50be8f5d /gnu
parent35869e854c402c54df76f141b2d5adebea7420c2 (diff)
downloadguix-8382a6d8bae23ee83ebcab6253076bcaf18ebcdf.tar.gz
gnu: Add trytond-dashboard.
* gnu/packages/tryton.scm (trytond-dashboard): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4f7bd60d12..aea203cd8c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1762,6 +1762,27 @@ currency and rate.")
 duty based on the tariff code.")
     (license license:gpl3+)))
 
+(define-public trytond-dashboard
+  (package
+    (name "trytond-dashboard")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_dashboard" version))
+       (sha256
+        (base32 "1drqiks8r7y58wz0skfa39v9yqx9fi5x0ymrrjd87wybw9q3kv46"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "dashboard"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)))
+    (home-page "https://docs.tryton.org/projects/modules-dashboard")
+    (synopsis "Tryton module for dashboard")
+    (description "The @emph{Dashboard} Tryton module allows users to
+configure their dashboard.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")