summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:02:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:50 +0300
commit92e817ea15c08654f8961d75fbd879266c3c9dad (patch)
tree37ce7d2558954cd933701b901f1b97ebdc5e7b14 /gnu
parent75ea06d8db27fb58fcf7a673af367b8805598d52 (diff)
downloadguix-92e817ea15c08654f8961d75fbd879266c3c9dad.tar.gz
gnu: Add julia-libvorbis-jll.
* gnu/packages/julia-jll.scm (julia-libvorbis-jll): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 1cf9b7deff..9e542fbf47 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -513,6 +513,44 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
     (description "This package provides a wrapper for libtiff")
     (license license:expat)))
 
+(define-public julia-libvorbis-jll
+  (package
+    (name "julia-libvorbis-jll")
+    (version "1.3.6+4")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/libvorbis_jll.jl")
+               (commit (string-append "libvorbis-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1zmwhpjy6gr865psjn600g6ickskp4sq34qf1qg8ji6x4v09pzrh"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"libvorbis\"")
+                    (string-append "\"" (assoc-ref inputs "libvorbis") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libvorbis" ,libvorbis)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-ogg-jll" ,julia-ogg-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/libvorbis_jll.jl")
+    (synopsis "Libvorbis library wrappers")
+    (description
+     "This package provides a wrapper for the libvorbis audio library.")
+    (license license:expat)))
+
 (define-public julia-mbedtls-jll
   (package
     (name "julia-mbedtls-jll")