summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 20:33:22 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:00 +0100
commit98d9869412156b0f786445f9e84184c5575f054a (patch)
tree582bb7d015ff392db774f379d599e890caff1710 /gnu
parentaec7c0cb447161bdaa0ac7e1d41feebb75cd3b7b (diff)
downloadguix-98d9869412156b0f786445f9e84184c5575f054a.tar.gz
gnu: python-tenacity: Update to 8.0.1.
* gnu/packages/python-xyz.scm (python-tenacity): Update to 8.0.1.
[propagated-inputs]: Remove.
[native-inputs]: Add PYTHON-TYPEGUARD.  Remove PYTHON-SPHINX.
[arguments]: Rewrite in gexp style.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1afc1a2850..7d3a8c7a5f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -710,25 +710,22 @@ threads.")
 (define-public python-tenacity
   (package
     (name "python-tenacity")
-    (version "6.1.0")
+    (version "8.0.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "tenacity" version))
               (sha256
                (base32
-                "1j36v9fcpmmd4985ix0cwnvcq71rkrn5cjiiv0id9vkl4kpxh0gv"))))
+                "0bwkvjpjfyi9dgszzad9aww2vc00w3bczjnbifi92cp7wch2l923"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-setuptools-scm python-sphinx python-tornado
+     (list python-setuptools-scm python-tornado python-typeguard
            python-pytest))
-    (propagated-inputs
-     (list python-six))
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda _
-                      (invoke "pytest")
-                      #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda _ (invoke "pytest" "-vv"))))))
     (home-page "https://github.com/jd/tenacity")
     (synopsis "Retrying library for python")
     (description "Tenacity is a general-purpose python library to simplify the