summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-06-28 15:08:52 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-06-28 15:08:52 +0200
commita7288095b51b822149ba31e79ba8f8278aa7ce78 (patch)
tree8a02eb49aa899fe17df8679cab559230e776f608 /gnu
parent80867e6b5e1911e7da877372422956aec111946f (diff)
downloadguix-a7288095b51b822149ba31e79ba8f8278aa7ce78.tar.gz
gnu: Add texlive-xpatch.
* gnu/packages/tex.scm (texlive-xpatch): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6b63368a0e..bafc3ce9a1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10931,3 +10931,19 @@ possible to register these float types with endfloat.")
 @item upright Greek letters in maths
 @end itemize")
     (license license:lppl1.2+)))
+
+(define-public texlive-xpatch
+  (package
+    (inherit (simple-texlive-package
+              "texlive-xpatch"
+              (list "doc/latex/xpatch/"
+                    "source/latex/xpatch/"
+                    "tex/latex/xpatch/")
+              (base32
+               "0r08hadnwx9vyppzmbn1bj69b12i5fw1mhk49piw2rqbk01722zk")
+              #:trivial? #t))
+    (home-page "https://www.ctan.org/pkg/xpatch")
+    (synopsis "Extending etoolbox patching commands")
+    (description "The package generalises the macro patching commands
+provided by Philipp Lehmann’s etoolbox.")
+    (license license:lppl1.3c+)))