summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-10-30 01:16:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-31 19:58:32 +0100
commita8631c816d78ede76f279e288efbb284090f8c91 (patch)
treef0596e16d19d3c82c2acf3a52f6c03bbc62c2866 /gnu
parent41461b6e22bbad937737d1a5ca4f2826d09a8463 (diff)
downloadguix-a8631c816d78ede76f279e288efbb284090f8c91.tar.gz
gnu: Add r-decomplexdisease.
* gnu/packages/bioconductor.scm (r-decomplexdisease): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e25c4d0e95..e4c8d9cdb5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3220,6 +3220,39 @@ reveals feature associations to hidden subclasses not exclusively related to
 higher deregulation levels.")
     (license license:gpl3+)))
 
+(define-public r-decomplexdisease
+  (package
+    (name "r-decomplexdisease")
+    (version "1.16.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "DEComplexDisease" version))
+              (sha256
+               (base32
+                "09a967x1rnv7byjwh29ngjhs67rgg27zblmlzx6pyqlwy5jsp89d"))))
+    (properties `((upstream-name . "DEComplexDisease")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocparallel
+           r-complexheatmap
+           r-deseq2
+           r-edger
+           r-rcpp
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/DEComplexDisease")
+    (synopsis "Investigations of complex diseases by bi-clustering analysis")
+    (description
+     "DEComplexDisease is designed to find the @acronym{DEGs, Differential
+Expressed Genes} for complex disease, which is characterized by the
+heterogeneous genomic expression profiles.  Different from the established DEG
+analysis tools, it does not assume the patients of complex diseases to share
+the common DEGs.  By applying a bi-clustering algorithm, DEComplexDisease
+finds the DEGs shared by as many patients.  Applying the DEComplexDisease
+analysis results, users are possible to find the patients affected by the same
+mechanism based on the shared signatures.")
+    (license license:gpl3)))
+
 (define-public r-deconvr
   (package
     (name "r-deconvr")