summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-19 15:17:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-20 08:57:01 -0500
commitafacad8b67d624b2b0f206acb7233785a296be7c (patch)
treeba40724f401c2a1a86f1cecfc60c181cfb73537a /gnu
parentb342b68c83a0231fd35cf205a94b754d10ff162e (diff)
downloadguix-afacad8b67d624b2b0f206acb7233785a296be7c.tar.gz
gnu: gnome-shell: Update to 41.0.
* gnu/packages/gnome.scm (gnome-shell): Update to 41.0.
[origin]: Remove patches and modules fields.
[phases]{pre-check}: Set HOME.
* gnu/packages/patches/gnome-shell-disable-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm9
-rw-r--r--gnu/packages/patches/gnome-shell-disable-test.patch24
3 files changed, 4 insertions, 30 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 54b23c06d9..77f355a76d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1165,7 +1165,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/gnash-fix-giflib-version.patch	        \
   %D%/packages/patches/gnome-online-miners-tracker-3.patch	\
   %D%/packages/patches/gnome-screenshot-meson-0.60.patch	\
-  %D%/packages/patches/gnome-shell-disable-test.patch		\
   %D%/packages/patches/gnome-settings-daemon-gc.patch		\
   %D%/packages/patches/gnome-tweaks-search-paths.patch		\
   %D%/packages/patches/gnupg-default-pinentry.patch		\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8c3ad06856..ebe718ab4a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8753,7 +8753,7 @@ properties, screen resolution, and other GNOME parameters.")
 (define-public gnome-shell
   (package
     (name "gnome-shell")
-    (version "40.5")
+    (version "41.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -8761,9 +8761,7 @@ properties, screen resolution, and other GNOME parameters.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0kph3g4ix23sm3ip2b13rs7hx8sa7fvlvcyy4zdk2iaj56rmadvd"))
-              (patches (search-patches "gnome-shell-disable-test.patch"))
-              (modules '((guix build utils)))))
+                "0ragmcln210zvzhc2br33yprbkj9drjzd7inp5sdxra0a7l73yaj"))))
     (build-system meson-build-system)
     (arguments
      `(#:meson ,meson-0.59         ;positional arguments error with meson 0.60
@@ -8811,7 +8809,8 @@ properties, screen resolution, and other GNOME parameters.")
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Tests require a running X server.
              (system "Xvfb :1 &")
-             (setenv "DISPLAY" ":1")))
+             (setenv "DISPLAY" ":1")
+             (setenv "HOME" "/tmp")))   ;to avoid "fatal" warnings
          (add-after 'install 'wrap-programs
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out              (assoc-ref outputs "out"))
diff --git a/gnu/packages/patches/gnome-shell-disable-test.patch b/gnu/packages/patches/gnome-shell-disable-test.patch
deleted file mode 100644
index c61ff4a942..0000000000
--- a/gnu/packages/patches/gnome-shell-disable-test.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This test seems to require a D-Bus connection not available in the build
-environment.
-
---- a/src/st/meson.build	2021-09-21 19:07:38.673049200 +0000
-+++ b/src/st/meson.build	2021-09-26 18:23:38.461569826 +0000
-@@ -191,18 +191,6 @@
-   sources: st_enums[1]
- )
- 
--test_theme = executable('test-theme',
--  sources: 'test-theme.c',
--  c_args: st_cflags,
--  dependencies: [mutter_dep, gtk_dep, libxml_dep],
--  build_rpath: mutter_typelibdir,
--  link_with: libst
--)
--
--test('CSS styling support', test_theme,
--  workdir: meson.current_source_dir()
--)
--
- libst_gir = gnome.generate_gir(libst,
-   sources: st_gir_sources,
-   nsversion: '1.0',