summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-06 22:30:43 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-06 22:45:47 +0100
commitb53355f08d15e919023c3fb77d27ba9e3d889880 (patch)
tree251fe8084ea6c5deeb5d89e85a0718969b55173f /gnu
parent93d8aad5215a1483931997bdc1bff8300ea9056e (diff)
downloadguix-b53355f08d15e919023c3fb77d27ba9e3d889880.tar.gz
gnu: emacs-deadgrep: Update to 0.12.
* gnu/packages/emacs-xyz.scm (emacs-deadgrep): Update to 0.12.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm71
1 files changed, 34 insertions, 37 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 40ba1bd31e..ab5f08a5db 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23861,44 +23861,41 @@ accept and reject GitHub pull requests.")
       (license license:gpl3+))))
 
 (define-public emacs-deadgrep
-  ;; Latest release is not tagged.
-  (let ((commit "aebaf72e35546fd235b4861399791814e4e4c7d8")
-        (revision "1"))
-    (package
-      (name "emacs-deadgrep")
-      (version (git-version "0.11" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/Wilfred/deadgrep")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "1qd60winrrpxmrjsx77i24921p6dad9halz5l5s6biwa421zcgr3"))))
-      (build-system emacs-build-system)
-      (inputs (list ripgrep))
-      (propagated-inputs
-       (list emacs-dash emacs-s emacs-spinner))
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'configure
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let ((ripgrep (assoc-ref inputs "ripgrep")))
-                 ;; .el is read-only in git.
-                 (make-file-writable "deadgrep.el")
-                 ;; Specify the absolute file names of rg so that everything
-                 ;; works out-of-the-box.
-                 (emacs-substitute-variables "deadgrep.el"
-                   ("deadgrep-executable"
-                    (string-append ripgrep "/bin/rg")))))))))
-      (home-page "https://github.com/Wilfred/deadgrep")
-      (synopsis "Frontend for @code{ripgrep}")
-      (description "This package provides an Emacs interface for performing
+  (package
+    (name "emacs-deadgrep")
+    (version "0.12")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Wilfred/deadgrep")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0bwf8gsqw7hsmacqd34piwgv066ijfclmxaigkvhvpac0lpsmi79"))))
+    (build-system emacs-build-system)
+    (inputs (list ripgrep))
+    (propagated-inputs
+     (list emacs-dash emacs-s emacs-spinner))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((ripgrep (assoc-ref inputs "ripgrep")))
+               ;; .el is read-only in git.
+               (make-file-writable "deadgrep.el")
+               ;; Specify the absolute file names of rg so that everything
+               ;; works out-of-the-box.
+               (emacs-substitute-variables "deadgrep.el"
+                 ("deadgrep-executable"
+                  (string-append ripgrep "/bin/rg")))))))))
+    (home-page "https://github.com/Wilfred/deadgrep")
+    (synopsis "Frontend for @code{ripgrep}")
+    (description "This package provides an Emacs interface for performing
 searches with @code{ripgrep}.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-focus
   (package