summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-30 23:31:04 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-31 12:18:06 +0100
commitc9fb08a2b109c9d80dad7f69a82f8912cbd0e9a0 (patch)
tree498b45ae6dde69dae0233933152b0f9a8f69c21d /gnu
parenta618505eebf6a11777243bbbfc11cf632073b8ff (diff)
downloadguix-c9fb08a2b109c9d80dad7f69a82f8912cbd0e9a0.tar.gz
gnu: Add emacs-hare-mode.
* gnu/packages/emacs-xyz.scm (emacs-hare-mode): New variable.

Co-authored-by: ( <paren@disroot.org>
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5fa70a095..325ec7d287 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33643,6 +33643,30 @@ tree to go back to previous buffer states.  To use vundo, type @kbd{M-x vundo RE
 the buffer you want to undo.  An undo tree buffer should pop up.")
     (license license:gpl3+)))
 
+(define-public emacs-hare-mode
+  ;; XXX: Upstream did not tag any commit.  Using "Version:" keyword as base
+  ;; version.
+  (let ((commit "bb7b2faccb5939b0c8d4ffa6a6e28a0d2bc93dd6")
+        (revision "0"))
+    (package
+      (name "emacs-hare-mode")
+      (version (git-version "0.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.sr.ht/~bbuccianti/hare-mode")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "13vjlmxfgwiljzjwkzhxzz565y34fggsbp840bxlwbwa6lsfrsa8"))))
+      (build-system emacs-build-system)
+      (home-page "https://git.sr.ht/~bbuccianti/hare-mode")
+      (synopsis "Hare major mode for Emacs")
+      (description
+       "This package an Emacs major mode for the Hare programming language.")
+      (license license:gpl3+))))
+
 (define-public emacs-org-cliplink
   (let ((commit "13e0940b65d22bec34e2de4bc8cba1412a7abfbc")
         (revision "0"))