summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:38 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commitec9c9c28cd29239bd413c67c45c1254813f4b5f8 (patch)
tree368bd821b06fe15e5a9ff0f5a4b0a4a3fb25ffd1 /gnu
parente515d2891c78186f937d74f1d4af2bf32978aa89 (diff)
downloadguix-ec9c9c28cd29239bd413c67c45c1254813f4b5f8.tar.gz
gnu: Add trytond-sale-credit-limit.
* gnu/packages/tryton.scm (trytond-sale-credit-limit): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7661dc5149..07edc0c008 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3082,6 +3082,33 @@ composed of action lines which can:")
 @code{Complaint} model.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-credit-limit
+  (package
+    (name "trytond-sale-credit-limit")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_credit_limit" version))
+       (sha256
+        (base32 "1qj4lg5gjsqg27sv6l5afb3rgw46y008ywy6742w9ab6misy57dh"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_credit_limit"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-credit-limit" ,trytond-account-credit-limit)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-company" ,trytond-company)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-credit-limit")
+    (synopsis "Tryton module for sale credit limit")
+    (description "The @emph{Sale Credit Limit} Tryton module adds confirmed
+sale but not yet invoiced to the credit amount of the party and check the
+credit limit of the party when confirming a sale.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")