summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 03:27:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:32 +0100
commit15af040cc35895e779397ab42f53561666d9301a (patch)
treeddcaf659aeb5cc217c58d4792b66e4c842718ce5 /gnu
parent44b885656aa1eb1d2dff9ecda35149c71d51b1fe (diff)
downloadguix-15af040cc35895e779397ab42f53561666d9301a.tar.gz
gnu: python-flask: Update to 1.1.1.
* gnu/packages/python-web.scm (python-flask): Update to 1.1.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d1e09fc727..985d03f8d1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1728,20 +1728,22 @@ minimum of WSGI.")
 (define-public python-flask
   (package
     (name "python-flask")
-    (version "1.0.3")
+    (version "1.1.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "Flask" version))
               (sha256
                (base32
-                "1wxnhjlxwwjhjxmghykjhllpahv5pkdc5hln4ab6nab43s26sz5d"))))
+                "0ljdjgyjn7vh8ic1n1dc2l1cl421i6pr3kx5sz2w5irhyfbg3y8k"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             (invoke "python" "-m" "pytest"))))))
+             (setenv "PYTHONPATH" (string-append "./build/lib:"
+                                                 (getenv "PYTHONPATH")))
+             (invoke "pytest" "-vv" "tests"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (propagated-inputs