summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-02-18 11:50:12 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-18 14:14:40 +0100
commit33ce3f1c866231a3015411fdce18a3e72649e2f6 (patch)
tree82ffd9240ed55109c23e0b2572b40c9f16bf779b /gnu
parent0d1a6cffaf84b28f9eb395451ddd425636877178 (diff)
downloadguix-33ce3f1c866231a3015411fdce18a3e72649e2f6.tar.gz
gnu: lsh: Build with optimizations.
This is a followup to 1cdd6b09c8bc45c1ae5a16f16d5bcf33ab0ceb5e, which
inadvertently turned off optimizations.

* gnu/packages/ssh.scm (lsh)[arguments]: Add "-O2 -g" next to "-fcommon".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 363ff22e29..8e29968ea7 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2022 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -631,7 +631,7 @@ basis for almost any application.")
                            "CPPFLAGS=-DHAVE_ARGP_PARSE"
 
                            ;; Fix the build of lsh@2.1 with GCC 10.
-                           "CFLAGS=-fcommon")
+                           "CFLAGS=-O2 -g -fcommon")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-failing-tests