summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:39:47 +0200
commit36cb01066cc03b2d341b55f21ebba2156518a560 (patch)
treed0721ebb9fd704fcc5735a2d872eb5aa0cb305f6 /gnu
parent31e50e1f48308a78a04f9aced53f2c2706660b31 (diff)
downloadguix-36cb01066cc03b2d341b55f21ebba2156518a560.tar.gz
gnu: r-copyhelper: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-copyhelper): Move from here...
* gnu/packages/bioconductor.scm (r-copyhelper): ...to here.
[source]: Repalce 'string-append' by 'bioconductor-uri' with 'experiment.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm24
-rw-r--r--gnu/packages/bioinformatics.scm26
2 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2a7872cbd2..9118642e66 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1128,6 +1128,30 @@ average profile and heatmap of peaks binding to TSS regions, genomic
 annotation, distance to TSS, and overlap of peaks or genes.")
     (license license:artistic2.0)))
 
+(define-public r-copyhelper
+  (package
+    (name "r-copyhelper")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "CopyhelpeR" version 'experiment))
+       (sha256
+        (base32
+         "0x7cyynjmxls9as2gg0iyp9x5fpalxmdjq914ss7i84i9zyk5bhq"))))
+    (properties `((upstream-name . "CopyhelpeR")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/CopyhelpeR/")
+    (synopsis "Helper files for CopywriteR")
+    (description
+     "This package contains the helper files that are required to run the
+Bioconductor package CopywriteR.  It contains pre-assembled 1kb bin GC-content
+and mappability files for the reference genomes hg18, hg19, hg38, mm9 and
+mm10.  In addition, it contains a blacklist filter to remove regions that
+display copy number variation.  Files are stored as GRanges objects from the
+GenomicRanges Bioconductor package.")
+    (license license:gpl2)))
+
 (define-public r-genelendatabase
   (package
     (name "r-genelendatabase")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa92ae3916..85e586a174 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8486,32 +8486,6 @@ analysis, variant tools is project based and provides a whole set of tools to
 manipulate and analyze genetic variants.")
     (license license:gpl3+)))
 
-(define-public r-copyhelper
-  (package
-    (name "r-copyhelper")
-    (version "1.6.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://bioconductor.org/packages/release/"
-                           "data/experiment/src/contrib/CopyhelpeR_"
-                           version ".tar.gz"))
-       (sha256
-        (base32
-         "0x7cyynjmxls9as2gg0iyp9x5fpalxmdjq914ss7i84i9zyk5bhq"))))
-    (properties `((upstream-name . "CopyhelpeR")))
-    (build-system r-build-system)
-    (home-page "https://bioconductor.org/packages/CopyhelpeR/")
-    (synopsis "Helper files for CopywriteR")
-    (description
-     "This package contains the helper files that are required to run the
-Bioconductor package CopywriteR.  It contains pre-assembled 1kb bin GC-content
-and mappability files for the reference genomes hg18, hg19, hg38, mm9 and
-mm10.  In addition, it contains a blacklist filter to remove regions that
-display copy number variation.  Files are stored as GRanges objects from the
-GenomicRanges Bioconductor package.")
-    (license license:gpl2)))
-
 (define-public r-copywriter
   (package
     (name "r-copywriter")