summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-05 00:42:15 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-15 09:58:51 -0400
commit3b79afa6a83a2d68109afb8f85ab82596a531b3d (patch)
treefbd5dd195481341ae2d9aa63d763726a6aa39180 /gnu
parentb1a8b40818ed100a395b0e244457d2c6a6257912 (diff)
downloadguix-3b79afa6a83a2d68109afb8f85ab82596a531b3d.tar.gz
gnu: shotwell: Update to 0.30.4.
* gnu/packages/gnome.scm (shotwell): Update to 0.30.4.
[build-system]: Use meson-build-system.
[arguments]: Set glib-or-gtk? flag.
[native-inputs]: Add desktop-file-utils.  Remove itstool duplicate.  Order
inputs alphabetically.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 04cd56f0d0..9ccdcbd83c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4687,7 +4687,7 @@ metadata in photo and video files of various formats.")
 (define-public shotwell
   (package
     (name "shotwell")
-    (version "0.28.4")
+    (version "0.30.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -4695,16 +4695,18 @@ metadata in photo and video files of various formats.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "03k7n2kmzqn11kf3733w7m6xjh2b5q9xr84za2hli11fjymzaxm9"))))
-    (build-system glib-or-gtk-build-system)
+                "1yiz3j0y2yg6985y3alb3hpkfbv68n8ibys5gpwcjdhmhf3czg5p"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:glib-or-gtk? #t))
     (propagated-inputs
      `(("dconf" ,dconf)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("itstool" ,itstool)
+     `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
        ("gettext" ,gettext-minimal)
        ("gtk+" ,gtk+ "bin") ; gtk-update-icon-cache
        ("itstool" ,itstool)
+       ("pkg-config" ,pkg-config)
        ("vala" ,vala)))
     (inputs
      `(("glib:bin" ,glib "bin")