summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-03-10 22:55:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-03-10 22:55:42 +0200
commit440b16290076b660347c2196a346a0538cb35577 (patch)
tree8db9310be8ef3932e397f35ae91301c51aa47520 /gnu
parentf55aa0c7b72c6e4f08f77aa84e196895182860e7 (diff)
downloadguix-440b16290076b660347c2196a346a0538cb35577.tar.gz
gnu: enlightenment: Use 'loginctl' for system actions.
* gnu/packages/enlightenment.scm (enlightenment)[arguments]: Use
'loginctl' functions when powering off, sleeping, rebooting or
suspending the system.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/enlightenment.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 8550a89640..a0bf841415 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -286,9 +286,10 @@ Libraries with some extra bells and whistles.")
                  (("/bin/mount") (string-append utils "/bin/mount"))
                  (("/bin/umount") (string-append utils "/bin/umount"))
                  (("/usr/bin/eject") (string-append utils "/bin/eject"))
-                 ; TODO: Replace suspend and hibernate also.
-                 (("/sbin/shutdown -h now") "/run/current-system/profile/sbin/halt")
-                 (("/sbin/shutdown -r now") "/run/current-system/profile/sbin/reboot"))
+                 (("/etc/acpi/sleep.sh force") "/run/current-system/profile/bin/loginctl suspend")
+                 (("/etc/acpi/hibernate.sh force") "/run/current-system/profile/bin/loginctl hibernate")
+                 (("/sbin/shutdown -h now") "/run/current-system/profile/bin/loginctl poweroff now")
+                 (("/sbin/shutdown -r now") "/run/current-system/profile/bin/loginctl reboot now"))
                #t))))))
     (native-inputs
      `(("gettext" ,gettext-minimal)