summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-09-20 18:59:57 +0100
committerLudovic Courtès <ludo@gnu.org>2018-09-21 17:04:37 +0200
commit45201bf245856954cb8368c328e54773a0a81156 (patch)
treee74854c7a4dc8875fa338e936fab1a730eed0e3e /gnu
parentb0d1e60fff023e405c92c45b3c78538c3cbb7e6b (diff)
downloadguix-45201bf245856954cb8368c328e54773a0a81156.tar.gz
gnu: hdf5-parallel-openmpi: Really enable parallel build.
This fix ensures that the H5_HAVE_PARALLEL identifier is correctly set
in the file H5pubconf.h.

* gnu/packages/maths.scm (hdf5-parallel-openmpi)[arguments]: Add
the "--enable-parallel" flag to the list of configure flags.  Remove
the incompatible "--enable-cxx" flag.  Add 'mpi-setup' phase.

Signed-off-by: Ludovic Courtès <ludovic.courtes@inria.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 30f1610c1d..636b485260 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1037,10 +1037,13 @@ Swath).")
      `(("mpi" ,openmpi)
        ,@(package-inputs hdf5)))
     (arguments
-     (substitute-keyword-arguments `(#:configure-flags '("--enable-parallel")
-                                     ,@(package-arguments hdf5))
+     (substitute-keyword-arguments (package-arguments hdf5)
+       ((#:configure-flags flags)
+        ``("--enable-parallel" ,@(delete "--enable-cxx" ,flags)))
        ((#:phases phases)
         `(modify-phases ,phases
+           (add-after 'build 'mpi-setup
+             ,%openmpi-setup)
            (add-before 'check 'patch-tests
              (lambda _
                ;; OpenMPI's mpirun will exit with non-zero status if it