summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-12 16:54:29 +0100
committerMarius Bakke <marius@gnu.org>2022-12-12 20:23:31 +0100
commit58e33da5f5261bbc3f76fd10b4807ff493ad587c (patch)
treee90bf2a71b5b8e213d57b3f13f798b6e2976b52d /gnu
parent999783b92d549dfd53a305ad744fcc0048fa2479 (diff)
downloadguix-58e33da5f5261bbc3f76fd10b4807ff493ad587c.tar.gz
gnu: f2fs-tools: Reverse inheritance relationship.
* gnu/packages/linux.scm (f2fs-tools): Update to 1.14.0.
[arguments]: Remove obsolete #:configure-flags and trailing #t in phase.
[inputs]: Remove labels.
(f2fs-tools-1.7): Inherit from above; add #:configure-flags.
[inputs]: Remove labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9ea77069ca..ad892a332d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5932,10 +5932,10 @@ uncompressed size will not match the number given by @command{tar} or
 obviously it can be shared with files outside our set).")
     (license license:gpl2+)))
 
-(define-public f2fs-tools-1.7
+(define-public f2fs-tools
   (package
     (name "f2fs-tools")
-    (version "1.7.0")
+    (version "1.14.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -5943,25 +5943,21 @@ obviously it can be shared with files outside our set).")
                     "/f2fs-tools.git/snapshot/f2fs-tools-" version ".tar.gz"))
               (sha256
                (base32
-                "1m6bn1ibq0p53m0n97il91xqgjgn2pzlz74lb5bfzassx7159m1k"))))
-
+                "1lab1446c78xsjwhpki7s85z4171m8p9279c8yhm4882wba674k1"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("CFLAGS=-fcommon")
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
          (add-after 'install 'install-headers
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (out-include (string-append out "/include")))
                (install-file "include/f2fs_fs.h" out-include)
-               (install-file "mkfs/f2fs_format_utils.h" out-include)
-               #t))))))
+               (install-file "mkfs/f2fs_format_utils.h" out-include)))))))
     (native-inputs
      (list autoconf automake libtool pkg-config))
     (inputs
-     `(("libuuid" ,util-linux "lib")
-       ("libselinux" ,libselinux)))
+     (list `(,util-linux "lib")))       ;for libuuid
     (home-page "https://f2fs.wiki.kernel.org/")
     (synopsis "Userland tools for f2fs")
     (description
@@ -5972,11 +5968,11 @@ disks and SD cards.  This package provides the userland utilities.")
     ;; GPL2/LGPL2.1, everything else is GPL2 only. See 'COPYING'.
     (license (list license:gpl2 license:lgpl2.1))))
 
-(define-public f2fs-tools
+(define-public f2fs-tools-1.7
   (package
-    (inherit f2fs-tools-1.7)
+    (inherit f2fs-tools)
     (name "f2fs-tools")
-    (version "1.14.0")
+    (version "1.7.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -5984,9 +5980,13 @@ disks and SD cards.  This package provides the userland utilities.")
                     "/f2fs-tools.git/snapshot/f2fs-tools-" version ".tar.gz"))
               (sha256
                (base32
-                "1lab1446c78xsjwhpki7s85z4171m8p9279c8yhm4882wba674k1"))))
+                "1m6bn1ibq0p53m0n97il91xqgjgn2pzlz74lb5bfzassx7159m1k"))))
     (inputs
-     `(("libuuid" ,util-linux "lib")))))
+     (list `(,util-linux "lib") libselinux))
+    (arguments
+     (substitute-keyword-arguments (package-arguments f2fs-tools)
+       ((#:configure-flags _ #~'())
+        #~'("CFLAGS=-fcommon"))))))
 
 (define-public f2fs-tools/static
   (static-package