summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-08-24 16:06:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-08-24 16:06:46 +0200
commit6199ee19ff84f904972fcc703442dff24018ef4d (patch)
treeed93b0d91ce8065b4ca3ce06aed6f128931ed8b4 /gnu
parent1e16af13b02dfe4b56267af2258694f1baf09e6c (diff)
downloadguix-6199ee19ff84f904972fcc703442dff24018ef4d.tar.gz
gnu: crawl: Honor the #:tests? flag.
* gnu/packages/games.scm (crawl)[arguments]<#:phases>: Honor the #:tests? flag
in custom check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 71abc57dd2..ebf805c119 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6568,15 +6568,16 @@ fish.  The whole game is accompanied by quiet, comforting music.")
                 (("SDL_image.h") "SDL2/SDL_image.h"))))
           (delete 'configure)
           (replace 'check
-            (lambda* (#:key make-flags #:allow-other-keys)
-              (setenv "HOME" (getcwd))
-              ;; Fake a terminal for the test cases.
-              (setenv "TERM" "xterm-256color")
-              ;; Run the tests that don't require a debug build.
-              (apply invoke "make" "nondebugtest"
-                     (format #f "-j~d" (parallel-job-count))
-                     ;; Force command line build for test cases.
-                     (append make-flags '("GAME=crawl" "TILES="))))))))
+            (lambda* (#:key tests? make-flags #:allow-other-keys)
+              (when tests?
+                (setenv "HOME" (getcwd))
+                ;; Fake a terminal for the test cases.
+                (setenv "TERM" "xterm-256color")
+                ;; Run the tests that don't require a debug build.
+                (apply invoke "make" "nondebugtest"
+                       (format #f "-j~d" (parallel-job-count))
+                       ;; Force command line build for test cases.
+                       (append make-flags '("GAME=crawl" "TILES=")))))))))
     (synopsis "Roguelike dungeon crawler game")
     (description "Dungeon Crawl Stone Soup (also known as \"Crawl\" or DCSS
 for short) is a roguelike adventure through dungeons filled with dangerous